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ABOUT THIS DOCUMENT

This document describes the Chronolator tools that help to complete, merge, format, and review
chronology tables.
It also contains some hints and ps about using Word tables in general, and a complete list of
Chronolator messages.
For informa on about the terminology used in this document (such as Internal Chronology and Local
Administrator), see the Glossary.

OTHER MAJOR DOCUMENTS
Se ng Up Chronolator Documents describes how to create Chronolator Documents using the
Chronolator Online Workbench, and how to distribute them.
Using Chronolator Samples contains some exercises you can undertake with the sample documents to
acquaint yourself with the main features of Chronolator.

SUPPLEMENTARY DOCUMENTS
The following supplementary documents are available in PDF format.
Chronolator Installa on Veriﬁca on Procedure

A er you have downloaded and
unzipped Chronolator you can use the
procedure described in this document
to check the installa on of the
Chronolator Online Workbench.

Chronolator Version 4.0 Release Notes

Summarises the changes made
between Chronolator Versions 3.5 and
4.0.

Ge ng a non-Chronolator review into Chronolator

New customers have o en already
started a review before they buy a
Chronolator licence. This document
outlines how Chronolator can be used
to improve the process of assembling a
mul -agency chronology from a
collec on of non-Chronolator
documents.

Group Policy Se ngs for Chronolator macros

For IT departments, this document
describes Microso Oﬃce Group Policy
Administra ve Templates that aﬀect
the ability to run macros, and thus the
ability to run Chronolator.
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INTRODUCTION

2.1 WHAT IS CHRONOLATOR AND WHAT DOES IT DO?
Chronolator was originally wri en for Microso Word. It is now complemented by some tools
at tools.chronolator.com that run in a Web browser such as Chrome.
This Help is about Chronolator for Word, apart from the topic Working with the Browser Tools
(sec on 4).
Chronolator makes it easy to produce and review the chronologies that are needed to review
interac ons between diﬀerent agencies and organisa ons.
Li le specialist knowledge is required to use it. There are no new programs to learn or install, and only a
basic knowledge of working with Word tables is required.
Chronolator has something to help everyone involved in using a chronology to inves gate a case:
those who supervise and administer it
the front-line staﬀ who input the data
those who review it

ADMINISTRATORS
Gathering and colla ng chronologies from mul ple agencies is a me consuming task, par cularly if
they each have diﬀerent ideas about what they need to provide. Chronolator enforces the standards set
by the administrator (for example, what column headings the chronology table should have) and
automates the merging of individual chronologies.

FRONT-LINE STAFF
Transcribing wri en records from various sources into a consistent format is a tedious and error-prone
task. Chronolator simpliﬁes the process with a number of tools. There are tools to sort records into
order, to put dates into consistent formats, and to check for a variety of problems.

REVIEWERS
The ﬁnal objec ve of a chronology is for someone to make sense of the events it contains. Chronologies
are o en anonymised, which can make it diﬃcult to build a mental picture of the people involved. The
Chronolator anonymisa on tool lets you switch back and forth between anonymised and personalised
views of a document.
Other tools for reviewers include:
naviga ng through a chronology according to entries in the Abbrevia ons Glossary
reports about items and individuals iden ﬁed in the Abbrevia ons Glossary
colour-coding events according to the agency repor ng them
a calculator to work out the interval between two dates
forma ng a tabular chronology into a narra ve layout
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an analysis tool summarising event counts by agency and date
The Chronolator Reviewer's Tool at tools.chronolator.com/review (one of the Chronolator Browser
Tools) includes many of these features, and also produces graphical melines.

THE CHRONOLATOR PROCESS
The Chronolator process begins when the Case Review Administrator sets up an Internal Chronology,
which is a Word document containing a table whose headings and other characteris cs are speciﬁed by
the Administrator.
The Case Review Administrator distributes the Internal Chronology to the various organisa ons whose
data is required.
If an organisa on needs to collect data from several departments, the recipient can forward the Internal
Chronology to them and ask them to complete it rather than calling for their original records. Anyone
forwarding a document in this way is called a Local Administrator.
When the holders of the original records have completed their documents, they return them to the
Administrator who wanted the informa on (either the Case Review Administrator or a Local
Administrator). That Administrator uses Chronolator to merge them into a Composite Chronology.
There is no limit to the number of levels of Local Administra on.
The diagrams below illustrate the ﬂow of documents between administrators and data collectors.
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MULTIPLE LEVELS OF ADMINISTRATION - A POSSIBLE SCENARIO

2.2 A NOTE ABOUT WORD VERSIONS AND OPTIONS
The illustra ons in this document were mostly taken in early 2020 using an Oﬃce 365 subscrip on with
a typical set of user op ons; your own experience might be slightly diﬀerent. Separate instruc ons are
provided for each Word version if there are marked diﬀerences.
Chronolator documents are supplied in the docm format introduced with Word 2007. They can be
opened in Word XP and 2003 if the Microso Oﬃce Compa bility Pack is installed. They can be saved in
the old doc format if need be.

LIMITED SUPPORT FOR WORD 2000
Word 2000 is no longer supported by Microso . Macros in docm ﬁles are not supported in Word 2000
even if the Compa bility Pack is installed. Word 2000 is therefore not suitable if you want to use the
Chronolator Online Workbench.
If you are using Word 2000 and your administrator has sent you an Internal Chronology as a docm ﬁle,
ask them to save and send you a doc version.
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WORD FOR APPLE MAC
Chronolator is designed for and tested on Windows versions of Word. It will certainly not work with
Word 2008 for Mac, as it does not include the Visual Basic for Applica ons programming environment
used to run macros. It might run OK on other versions of Word for Mac, but it is not tested on them and
support is not guaranteed.

HOW CAN I TELL WHICH VERSION OF WORD I AM USING?
The simplest way is to look at the 'splash screen' Word displays while it starts, although this will not
show any diﬀerence between Word 2013 and 2016.
Word XP

Word 2003

Word 2007

Word 2010

Word 2013 and
later

Alterna vely, type how can I tell which version of Word I am using into a search engine. At the me of
wri ng, the most useful link this revealed was on Microso 's web site:
h p://oﬃce.microso .com/en-gb/word-help/what-version-of-oﬃce-am-i-using-HA101873769.aspx.
(Short link: h ps:// nyurl.com/whichOﬃceVersion).

2.3 PRACTISE USING CHRONOLATOR
If you want to prac se using Chronolator you can use the sample ﬁles supplied with it alongside the
Using Chronolator Samples Online Help or document.
If you do not have the samples you can download them from
www.chronolator.com/downloads/download-samples.htm.

2.4 GETTING HELP
ONLINE DOCUMENTATION
All the wri en documents for Chronolator are available online. See About this document (sec on 1) for a
list of these documents.

VIDEOS
Chronolator provides a number of videos which illustrate its features and how to accomplish many of
the tasks you need to undertake.
See www.chronolator.com/demonstra ons for feature overviews for prospec ve purchasers,
and www.chronolator.com/tutorials for more detailed explana ons of individual tasks.
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KNOWLEDGEBASE AND PROBLEM REPORTING
If you cannot ﬁnd what you need in the above documenta on and videos, or you want to report a
problem, use the customer portal at support.chronolator.com.

ACCESSING HELP FROM A CHRONOLATOR DOCUMENT
All the above are available using links on the Help bu on on the Chronolator toolbar.

2.5 SYSTEM REQUIREMENTS
MICROSOFT WORD
Chronolator works with all versions of Word for Windows from XP up, including 64 bit versions where
available.
Macros must be enabled.
See A note about Word versions and op ons (sec on 2.2) for informa on about Word for Mac.
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WORKING WITH CHRONOLATOR DOCUMENTS

Chronolator Documents are Microso Word documents with extra features. All standard Word features
are available and work in the usual way.
If you receive a Chronolator Document as an email a achment, you should save it somewhere on
your system and work on the saved copy. This avoids the loss of work which can arise from
working directly on any email a achment.
Word might require you to allow some ac ons before it ini alises Chronolator. In par cular:
you might need to Enable Edi ng if the document opens in Protected View
you might need to Enable macros, depending on your macro security se ngs
You will also need to accept the terms of the Chronolator licence if you have not already done so since
you opened Word.
For details, please refer to the following:
Protected View (sec on 15.1.1)
Enabling macros (sec on 15.1.2)
Licensing (sec on 15.1.3)
A er you have completed any of the above tasks that are required, Chronolator adds a toolbar (sec on
5) to the Word Ribbon.
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WORKING WITH THE BROWSER TOOLS

The Chronolator Browser Tools provide a way to process chronologies in a Web Browser (Chrome and
Firefox for example).
It is important to note that only the so ware resides on the Web. Your chronologies stay on your
computer, completely under your control. Their conﬁden ality is not compromised.
However, the Browser tools and Chronolator for Word use diﬀerent types of ﬁle. This sec on describes
how to transfer chronologies between them.

TRANSFER FROM WORD TO THE CHRONOLATOR BROWSER TOOLS
On the Chronolator toolbar, press Publish > JSON to produce a ﬁle in JSON (JavaScript Object Nota on)
format:

Note that the JSON ﬁle is unencrypted and can be read by humans with a simple text editor. If you want
to prevent this, open it in any of the Chronolator Browser Tools and save it: this will produce a txt ﬁle
that only the browser tools can interpret.
If you want to further protect the chronology with a password, refer to the Help in the Browser Tool.

TRANSFER FROM THE CHRONOLATOR BROWSER TOOLS TO WORD
(OR EXCEL OR OTHER PROGRAM)
There are two ways to transfer data from the Chronolator Browser Tools to Word:
the Chronolator Conversion Tool
via the Clipboard
Use the Conversion Tool if you want to use Chronolator for Word features. If you only want to produce a
plain Word document, you can use the Clipboard.

USING THE CONVERSION TOOL
The conversion tool works on a JSON ﬁle created by the Browser Tool. Refer to the Browser Tool's Help
for details of how to create one.
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If you already have a Chronolator for Word licence, you will ﬁnd the Conversion Tool in the
ChronologySetup folder.
If you do not, you can download it from www.chronolator.com/downloads/download-conversiontool.htm.
In either case, the aforemen oned Web page includes instruc ons about how to use it.

USING THE CLIPBOARD
Step 1 - copy the chronology to the Clipboard
Refer to the Help in the Browser Tool for details of how to copy the chronology.

Step 2 - paste the Clipboard to another program
You can paste the clipboard into another applica on such as Microso Word or Excel (or, indeed, any
other).
You can paste the clipboard by using the Paste bu on on the Home tab, or by pressing Ctrl+V.
The following instruc ons assume you are pas ng into a new, blank Microso Oﬃce document.
A er pas ng
Excel should automa cally convert the data when you paste it into a blank spreadsheet.
A er pas ng into Word, you will need to convert the text to a table like this:
Select All (Ctrl+A)
Convert the selec on to a table using the Insert tab, choosing Table > Convert text to table and
using all the defaults
Line breaks: Word and Excel
If your table contained line breaks, they will have been transformed into the ` character .
Do the following to change them back into line breaks:
Select All (Ctrl+A)
Open the Replace dialog (Ctrl+H)
Type ` in the Find What box. You should ﬁnd it at the top le of your keyboard
(In Word): Type ^p in the Replace with box. You should ﬁnd the ^ character with Shi +6
(In Excel): Type Ctrl+Shi +J in the Replace with box
Press Replace All

© 2021 Berrick Computing Ltd. All Rights Reserved.
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CHRONOLOGY DOCUMENT TOOLBARS

A er you accept the licence terms, Chronolator creates a new Toolbar on the Ribbon's Add-Ins tab. Click
Add-ins to display it.
If a Chronolator toolbar does not appear, see The Chronolator toolbar does not appear (sec on 11.1).
Diﬀerent Chronology Document types have diﬀerent toolbars as shown below.

COMMON BUTTONS
The Advanced and Help bu ons are included on every toolbar. The former provides facili es that you
should normally use only if asked to by Chronolator support. The la er provides links to this Help and to
other learning tools.

THE INTERNAL CHRONOLOGY TOOLBAR

The Internal Chronology toolbar provides several features to simplify the produc on of an accurate
chronology which can easily be merged with others. These features are described in detail elsewhere in
this Help, but here is a summary of what they do:
The Admin menu has bu ons for various administra ve tasks, such as:
viewing internal informa on about the document
crea ng a Composite Chronology containing chronologies from diﬀerent departments and
organisa ons
The Tools menu helps you:
calculate the interval between two dates
use the Abbrevia ons Glossary to search through, anonymise and re-personalise a document
ﬁnd duplicated rows
add reference numbers to a chronology, and specify the order of events on a day when their exact
mes are unknown
highlight events according to the agency that reported them
use Chronolator Add-ins to provide addi onal func ons
The Format Dates menu changes dates and mes to a consistent format, including op ons to include
the day of the week.
The Sort Tables menu sorts the rows of a table into ascending or descending date and me order.
The Check Tables bu on checks the data in a document on demand (Chronolator also checks it when
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you close an Internal Chronology document).
The
The

bu ons navigate from one error to the next.
bu on takes you to list of errors at the end of the document.

The Publish menu creates an exact copy of the document without any Chronolator macros. It also allows
you to produce the chronology table in several narra ve formats, and to produce an analysis of the
chronology.
The Advanced menu contains some func ons that should normally only be used if you are asked to do
so by Chronolator support staﬀ.
The Help menu provides links to this Help and other learning tools.

THE NEW COMPOSITE CHRONOLOGY TOOLBAR

A new Composite Chronology does not 'know' anything about the case it is going to include - it gets that
informa on from the ﬁrst chronology you import.
To keep the toolbar simple, the New Composite Chronology toolbar only includes a bu on to Import
Tables from a chronology.

THE OLD COMPOSITE CHRONOLOGY TOOLBAR

The Old Composite Chronology toolbar is the same as the Internal Chronology toolbar in this sec on,
with the addi on of the Import Tables and Merge Tables bu ons.
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CHRONOLATOR FEATURES - A SUMMARY

6.1 ENTERING AND CHECKING EVENTS
Chronolator aims to make it as easy as possible to transcribe paper and other records into chronology
tables. For example:
you can enter records as they become available and sort them later
you can type in dates just as they are wri en, and let Chronolator put them in a consistent format
Chronolator checks that the events in a chronology table are in order and that what is entered ﬁts
the criteria set by the Case Review Administrator

6.2 PRODUCING COMPOSITE CHRONOLOGIES
Informa on is o en needed from several diﬀerent departments within an organisa on. Chronolator
speeds the process of ge ng this informa on by le ng you forward an Internal Chronology to other
people for them to complete. When they return their completed copies, you can use Chronolator to
combine them into a Composite Chronology. Crea ng Composite Chronologies is described in Crea ng a
Composite Chronology document (sec on 8).

6.3 PRODUCTIVITY TOOLS AND ADVANCED FEATURES
Chronolator provides several other tools to facilitate working with chronologies. These are described
in Produc vity Tools (sec on 9) and in Advanced macros (sec on 15.4).

6.4 PRACTISE USING CHRONOLATOR
If you want to prac se using Chronolator you can use the sample ﬁles supplied with it alongside the
Using Chronolator Samples Online Help or document.
If you do not have the samples you can download them from
www.chronolator.com/downloads/download-samples.htm.
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WHAT IS IN A CHRONOLATOR DOCUMENT?

A Chronolator Document consists of an op onal preamble and one or more Chronology Tables:
the Case Review Administrator can include a preamble containing details of the case and a brief
descrip on of how to use Chronolator
the Chronology Table is where you enter details about the case under review
Chronolator ignores the document preamble, processing only the Chronology Table(s).

7.1 ENTERING DATA IN THE CHRONOLOGY TABLE
If you receive a Chronolator Document as an email a achment, you should SAVE IT SOMEWHERE
ON YOUR SYSTEM AND WORK ON THE SAVED COPY. This avoids the loss of work which can arise
from working directly on any email a achment.
Entering data into a Chronology Table requires a basic knowledge of working with Word tables – how to
create a new row, how to move a row and so on. If you are unfamiliar with these ideas, you will ﬁnd
some hints and ps in Working with Microso Word tables (sec on 10).
When an Internal Chronology is created, the Case Review Administrator speciﬁes the rules which must
be followed in the Chronology Table – for example, what the column headings are and which columns
must always be completed. The Administrator should tell you what these rules are, either in the
document preamble or in a covering le er. Chronolator checks that the data you enter conforms to
these rules every me you close the document, and warns you if it ﬁnds any problems. You should
correct any errors before returning the document.
It is essen al that you do not change, add or remove any headings in the Chronology Table, as
Chronolator relies on them to check the data you enter. You can change the font, the column widths, the
shading and so on, but you must not change the heading text or add or remove columns.
Chronolator always formats the chronology table with the Normal style. If you want to ensure that
changes you make to the font are preserved during Chronolator processing, you should update the
Normal style. Refer to Word Help for more informa on about forma ng a document with styles.
If you accidentally change the headings and forget what they should be, you can generate a new set
at the end of the document by pressing the Admin > New Table bu on on the Chronolator toolbar.
A er doing this, either copy any data you have already entered into the new table, or copy the
heading row from the new table into that of the old one.

7.2 SPECIAL COLUMNS
Chronolator treats most of the columns in a chronology table as free-form text, only checking them if
the Case Review Administrator has deemed them mandatory. However, some columns play a major role
in the way a Chronolator Document is processed.
These special columns are described below.

© 2021 Berrick Computing Ltd. All Rights Reserved.
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Chronolator's names for them are shown like this, but the Case Review Administrator can give
them diﬀerent headings in the actual chronology table.

Event order: Date, Time and Sequence columns
Up to ﬁve special columns can be used to specify when an event happened:
Sequence (op onal)
Start Date (mandatory for all Chronolator Documents)
Start Time (op onal)
End Date (op onal)
End Time (op onal)
Chronolator can populate the Sequence column with event reference numbers, which can also be used
to specify the order of events on a par cular day when you do not know their mes. If you need to do
this and the Administrator has not included one, you can add a Sequence column using the Tools >
Sequencing > Add column bu on (this is the only change you can make to Administrator-deﬁned
column headings).
Dates
Chronolator allows you to enter dates in many formats. For example, all the following will be recognised:
22.05.16
22-may-16
22/05/16
22/05/2016
Chronolator expects a Date column to contain a single date and no other words or characters except a
ques on mark at the start if you are unsure of the exact date. For example ? 22 may 2016 is OK, but 22
may 2016 ? and probably 22 may 2016 would not be allowed.
If you want to enter a range of dates and the Case Review Administrator has not included an End
Date column, enter the ﬁrst date in the Start Date column and the other date in one of the other
columns.
The Format Dates menu on the Chronolator toolbar lets you set all the dates you have entered in a Date
column into a consistent format. This means you can enter dates exactly as they are on the original
records, which is easier and less prone to error.
Times
Chronolator is also ﬂexible about the formats used in any Time columns in the table. For example, the
following will all be recognised:
0100
01.00
01:00

© 2021 Berrick Computing Ltd. All Rights Reserved.

Using Chronolator Documents

19

1 am
01 am
As with dates, if you are unsure of a me you can put a ques on mark before it.
The Format Dates menu on the Chronolator toolbar also puts all the mes you have entered in a
Time column into a consistent format; all the above would become 01:00. As with dates, you can
enter mes exactly as they are on the original records.

Source of Informa on column
A er the Event Order columns comes the Source of Informa on column, where you specify the source
of your informa on about the event.
When entering the source of your informa on, do not include your own organisa on or department.
This informa on will be added by the Administrator who sent you the document.
For example, suppose you work at the Berrick New Town Clinic and are entering data you have obtained
from a Health Visitor's notes. You should record the source of informa on simply as, say, HV notes, not
as Berrick New Town Clinic HV notes. The administrator who sent you the document will add Berrick
New Town Clinic when using Chronolator to combine chronologies. (You can see an example of this in
Specify where the document came from (sec on 8.3)).

Glossary column
A Glossary column can be included which should contain only abbrevia ons that have been deﬁned in
the Abbrevia ons Glossary - for example, somebody's ini als. This can be useful when a chronology
contains informa on pertaining to more than one person. Chronolator will check that anything in this
column has been deﬁned in the Abbrevia ons Glossary.
You can view the glossary and add your own abbrevia ons to it by pressing the Tools > Glossary > Edit
bu on on the Chronolator toolbar. Each abbrevia on can be up to ten characters long, and its deﬁni on
up to thirty.
You can anonymise and personalise a document by using the Abbrevia ons Glossary in conjunc on
with the Tools > Glossary > Anonymisa on and Review bu on.
You can search and navigate through a document by using the Abbrevia ons Glossary in
conjunc on with the Tools > Glossary > Anonymisa on and Review bu on.

Mandatory columns
Chronolator insists that the Start Date and Source of Informa on columns must always be completed.
The Case Review Administrator decides what other columns are mandatory.

Finding what special columns are included
The Admin > Show Document Details bu on on the Chronolator toolbar displays a summary of what
special columns and abbrevia ons the Case Review Administrator has set up.
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It will usually be obvious from the column headings what type of data is expected. If not, ask the person
who sent you the document to explain them.

7.3 CHECKING FOR ERRORS
Chronolator checks your Internal
Chronology document every me you
close it. If it ﬁnds errors, it displays
Message 3005.
Press Cancel to keep the document
open so you can correct the errors.
Press OK if you want to correct them
later. The document will close.

You can also check the document whenever you want by pressing the Check Tables bu on on the
Chronolator toolbar:
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If the document is error-free it will tell
you:

If the document contains errors,
Message 3000 is displayed. The
number in brackets says how many
errors were found.
Like all Chronolator messages, it
has some sugges ons about what
you might do next. In this case,
the message describes how you
can ﬁnd out more about the
errors.
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There are several ways for you to ﬁnd
the errors Chronolator iden ﬁes,
illustrated in this picture:
A ﬂag like this ⌧ is put at the
le of the error
Hovering your mouse over the
ﬂag displays a brief descrip on.
Error text is highlighted. Invalid
data is coloured turquoise, valid
dates or mes which are out of
sequence are coloured yellow,
and rows with the wrong
number of columns are coloured
purple.
Use the
bu ons
on the Chronolator toolbar to go
from one error to the next. This
is useful if you are working in a
long document
There is a complete list of errors
at the end of the document. Use
the
bu on to the right of
the naviga on bu ons to go
there

7.4 CORRECTING ERRORS
The following example (taken from SampleTableWithErrors.docm in the Samples folder) illustrates the
sort of errors Chronolator discovers, and shows how you might go about correc ng them.
In this example, the Administrator has speciﬁed that you can leave any column blank apart from the Date
and Source of Informa on columns.
The text in the Comments column describes the sort of errors Chronolator will ﬁnd. It is not itself
part of Chronolator's checking.
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A er Chronolator checks the table, it puts a ﬂag like this ⌧ to the le of any errors and highlights them :

If you hover your mouse over the ﬂag, a brief descrip on of the error pops up.
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Here, Chronolator warns that it has corrected
a row with the wrong number of columns and
advises you to check that it has put
informa on under the right headings.

In this example, Chronolator has detected a
blank entry in a mandatory column.

The bu ons on the Chronolator toolbar navigate from one error to the next:

This bu on takes you to a list of the errors:

The list of errors is at the end of the document.
Double-click the ⌧ ﬂag to go to where the error
occurs.

Error descrip ons are preceded by a reference number (e.g. c8n120). If you have diﬃculty correc ng an
error, use the reference number to look it up in Check Table Error Codes (sec on 12.10), where there
might be some useful hints.
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CAUTION: Anything you write in or a er the error list will be deleted next me Chronolator
checks the document.
How you correct errors in a real document will obviously be a ma er of judgment. For the purposes of
this example, this is what we will do:
add text to all the mandatory columns
review the rows which had the wrong number of columns, which are highlighted like this. In this
case we decide that Chronolator has placed the data correctly, and leave it where it is
correct the invalid date 34 may 2013 to 14 may 2013
copy and paste the required data over the See above text, and delete the di o marks and as above
text
The table now looks like this:

No ce that the corrected errors are s ll ﬂagged and highlighted (apart from the ones we corrected
with copy and paste). Chronolator does not check for errors as you type because doing so would
make your computer run very slowly. You need to check the document again . . .
Pressing the Check Tables bu on again results in this:
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Many of the problems Chronolator has found are out-of-sequence dates, which it has highlighted in
yellow. You could correct these by moving the rows about, or by changing the dates for some events,
depending on what is appropriate for the data you have entered.

7.5 THE SORT TABLES BUTTON
In the example above (sec on 7.4), you might decide that each event was in fact correctly dated but that
the rows were in the wrong order. Indeed, this is the most likely cause if you have been entering each
event in a new row at the bo om of the table as it came to hand. Chronolator will ﬁx this for you with
the Sort Tables bu on. When you press it, you can choose to sort the table in ascending or descending
order:

If you press Ascending, the table is sorted like this:
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Remember, Chronolator does not check for errors as you type; press the Check Tables bu on again
to remove the highligh ng:

All the events are now in order. Some errors remain, but we will leave them for now.

© 2021 Berrick Computing Ltd. All Rights Reserved.

Using Chronolator Documents

28

You might have entered dates just as they appeared in the source records; in the example above,
that is why two of the dates are in diﬀerent formats to the rest (22/05/2013 and 24 07 2013).
Chronolator can put them all into a consistent format for you; see Format Dates (sec on 8.3) for
details.

HOW DOES CHRONOLATOR SORT EVENTS WITH BLANK TIMES AND
END DATES?
The Case Review Administrator can include op onal End Date, Start Time or End Time columns. These
might not have to be completed for every event.
If so, you might wonder how Chronolator will deal with a mixture of events, some with completed mes
or end dates and some with blanks.
The answer depends on whether events are sorted in Ascending or Descending order. If Ascending,
events with blank Times or End Dates are put before those with speciﬁc informa on: if Descending,
a er. The following examples illustrate this.
Ascending order

Descending order
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CREATING A COMPOSITE CHRONOLOGY DOCUMENT

This sec on describes how to merge individual Chronolator Documents into Composite Chronologies.

8.1 ADMINISTRATORS
A Composite Chronology is produced by an Administrator. In Chronolator terminology, there are two
kinds of Administrator:
A Case Review Administrator has a licence for the Online Workbench and uses it to set the criteria
for an Internal Chronology
A Local Administrator is someone who, when they receive a Chronolator Document, decides to
delegate comple ng it to several other people in their organisa on
A Local Administrator distributes copies of the document to other people and merges them into a
Composite Chronology when they have been completed.
When the Composite Chronology has been completed, a Local Administrator returns it to the
person who asked them for the informa on.
The ﬂowcharts in What is Chronolator and what does it do? (sec on 2.1) illustrate the ﬂow of
documents between administrators and data collectors.
The only diﬀerence in administrators' procedures is that a Case Review Administrator should use the
Online Workbench to create a new Composite Chronology, while a Local Administrator must use the
Admin > New Composite Chronology bu on on the Chronolator Document toolbar
Using the Online Workbench to create the Composite Chronology ensures that it is licensed for as
long as the Online Workbench. Composite Chronologies created from an Internal Chronology are
only licensed for the same period as the Internal Chronology.

8.2 OVERVIEW
Crea ng a new Composite Chronology involves the following steps:
Make a blank Composite Chronology document
Import tables from the Chronolator Documents that have been returned to you
Merge the tables
Format the dates
Sort the tables
(Op onal) Apply any ﬁnal forma ng that is required
(Op onal) Publish the document with the Chronolator code removed
You can wait un l you have received all the documents before star ng this process, or you can import,
merge, format and sort each one as it comes in. It is up to you.
The following sec ons describe these processes step by step.

8.3 STEP BY STEP GUIDE
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STEP 1 - MAKE A BLANK COMPOSITE CHRONOLOGY DOCUMENT
How you make a blank Composite Chronology depends on what type of administrator you are:
If you are a Case Review Administrator

If you are a Local Administrator

Press the New Composite Chronology bu on
on the Online Workbench toolbar.

Press the Admin > New Composite Chronology bu on
on the Internal Chronology toolbar.

Chronolator displays Word's Save As
dialog for you to choose what to call
the new Composite and where to save
it.
Enter a suitable name and loca on and
press Save.
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For maximum compa bility with
other Word versions, and to avoid
some problems which occasionally
arise when emailing Word MacroEnabled Document ﬁles, change
the Save as type to Word 972003 Document before pressing
Save.

If you are a Case Review Administrator, the Online Workbench stays open when the Composite
Chronology is created. You might need to switch to the Composite Chronology using the Windows
taskbar.
If you are a Local Administrator, the Internal Chronology closes and the Composite Chronology is
opened.
From this point on, there are no diﬀerences between what Case Review Administrators and Local
Administrators do to produce a Composite Chronology.

STEP 2 - IDENTIFY THE COMPOSITE CHRONOLOGY TOOLBAR
The Composite Chronology has a new
toolbar. Chronolator never displays
bu ons for irrelevant tasks, so a new
Composite Chronology contains just
three bu ons:

A er you have imported the ﬁrst document, the toolbar expands to include bu ons for the other tasks
that become possible:
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STEP 3 - IMPORT CHRONOLOGY DOCUMENTS INTO THE COMPOSITE
CHRONOLOGY
IDENTIFY AND CHECK A FILE TO IMPORT
Although Chronolator will have warned people if it found errors in their documents, it cannot force them
to correct them. Before you import a document, you should open it and check it using the Check Tables
bu on on its own Chronolator toolbar.
If the document has errors which you cannot correct yourself, ask the person who sent it to you for
clariﬁca on, or return it to them for correc on; it is be er to sort things out now rather than later.
Chronolator will import a document with errors if you need to do so. Correc ng them before import
is simply our best prac ce recommenda on.
If you are sa sﬁed with the document, close it and return to your Composite Chronology.

PRESS THE IMPORT TABLES BUTTON
Press the Import Tables bu on to
display Word's Open dialog.
Open the document you want to
import.

When you import a document into a new Composite Chronology, Chronolator copies in the en re
document, including its preamble (if any) and the internally stored Case Details.
When you import subsequent documents, Chronolator checks that they relate to the same case and
copies all tables matching the Case Details to the end of the Composite Chronology.
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SPECIFY WHERE THE DOCUMENT CAME FROM
A er checking that the document
contains tables with the right
headings, Chronolator asks you to
iden fy where it came from. For
example, if you were to import a
document from the Police, you might
enter this:

When you press OK, Police > will be added to whatever is already in the Source of Informa on column.
For example, if the Police's document
contains this entry . . .

. . . a er you have imported it, it will look
like this:

You can import all the documents you have to hand before proceeding to the next step, or you
might prefer to import, merge, and format them one by one. It is up to you.

STEP 4 - MERGE TABLES IN A COMPOSITE CHRONOLOGY
Use the Merge Tables bu on to combine all the
tables in the Composite Chronology into a single
table.

Chronolator automa cally resizes any tables whose column widths are diﬀerent from those of the ﬁrst
table.

STEP 5 - FORMAT DATES
The various organisa ons and departments who completed the Internal Chronology documents you
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distributed will probably have entered dates in a variety of diﬀerent ways (01.02.16, February 1 2016,
1/2/16 and so on). This does not hamper Chronolator's validity checks, but it does look un dy.
You can use the Format Dates
bu on to put them all into a
consistent format. When you
press it, you will see today's date
displayed in four diﬀerent
formats. Press the one you want.

The available formats present January 26 2020 as 26 Jan 2020 or 2020-01-26. The la er is the ISO 8601
format. Both formats can be enhanced with the day of the week, which can be useful for a reviewer
trying to establish pa erns of behaviour.
When you format dates, any Time columns are also forma ed. The format conforms to ISO 8601 (a
24-hour me delimited by a colon, e.g. 18:15).

STEP 6 - SORT THE CHRONOLOGY
Use the Sort Tables bu on to sort the merged table into the correct order. When you press it, a menu
drops down so you can choose whether to sort the table in ascending or descending order.

Press the order you want. Chronolator will sort the table using the Date and Time columns that the Case
Review Administrator speciﬁed.
Chronolator puts un- med events for a par cular day before med events when sor ng in
Ascending order, or a er them when sor ng in Descending order. See How does Chronolator sort
events with blank mes and End Dates? (sec on 7.5) for an example.

SORTING MIXED FORMATS
Pu ng dates and mes into a consistent format before sor ng is recommended as it makes the sort
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easier for Word, and thus more reliable.
Early versions of Word had a bug which prevented Sort from working in some circumstances.
Circumven ng that bug was the reason for introducing the ISO 8601 format, which Word unfailingly
sorted correctly. If you do encounter problems sor ng, try this:
Press Format Dates and choose the ISO 8601 format
Press Sort Tables
Press Format Dates again and choose your desired format

STEP 7 - FINAL CHECKS
You can use the Check Tables bu on to make a ﬁnal check that the Composite Chronology is valid as far
as Chronolator is concerned.

You should also read through the document to make sure it makes sense. Chronolator certainly
simpliﬁes the process of producing these documents, but it is only a computer program and cannot
correct human failings!
In par cular, you might want to check that any me-cri cal events are in sequence if the document
does not contain Chronolator's Start Time or Finish Time columns, or if they have not been
completed. If they are not, consider using a Sequence column (see Using a Sequence column
(sec on 9.5)).

STEP 8 (OPTIONAL) - PUBLISHING A CHRONOLOGY DOCUMENT
When you have completed a chronology document you can publish it without the Chronolator program
code so that your recipients will not have to do anything about macros and licence terms whenever they
open it.
Pressing Publish > Exact Copy copies everything to a new document, and then displays Word's Save As
dialog so you can choose where to save it.
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The original Chronolator document is unchanged by this process.
As well as making an exact copy, you can:
publish the chronology in a variety of narra ve formats
create a document containing an analysis of the chronology
create a document in the JSON (JavaScript Standard Object Nota on) format that can be processed
by the Chronolator Browser Tools at tools.chronolator.com
See Publishing a chronology (sec on 9.8) for more details.
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PRODUCTIVITY TOOLS

The Tools menu contains the following features:
An Age and Interval Calculator - see The Age and Interval Calculator (sec on 9.1)
Anonymisa on and Personalisa on using the Abbrevia ons Glossary, including review of selected
abbrevia ons - see Anonymisa on and Personalisa on (sec on 9.3)
Duplicate Row Processing - see Working with Duplicated Rows (sec on 9.4)
Adding reference numbers to events, and using them to force the order in which they are sorted see Using a Sequence column (sec on 9.5)
Shortcuts to Word's Table Auto Fit and Split at Current Row tools
Highligh ng events according to their Source of Informa on - see Highligh ng Sources of
Informa on (sec on 9.7)
Using Add-ins, which add extra func ons to Chronolator - see Add-ins (sec on 9.9)

9.1 THE AGE AND INTERVAL CALCULATOR
You will o en want to work out the interval between
two dates when working on a chronology.
Chronolator provides a tool to do this for you when
you press Tools > Age Calculator on the Chronolator
toolbar.

If you have not used the Age and Interval Calculator
before in this document, Date 1 has today's date in it,
and Date 2 is blank.
If you have used it before and saved the
document, the last two dates you used will be
shown.
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You can type dates into the boxes in many formats. As
you type, Chronolator displays what it thinks you
mean next to the box.
When Chronolator can interpret dates in both boxes,
it calculates the interval between them.
The interval is shown as a number of days and as a
number of years, months and days.
It does not ma er which date is the earlier one.
You can copy the interval informa on to the Clipboard by pressing the Copy bu on, and then paste it into your
document. The example above is copied to the Clipboard as 1 year, 11 months, 27 days (514 days). Once
pasted into the document, you can edit it as you choose.
Using the Age and Interval Calculator is quite straigh orward, but it is worth no ng some details about how it
works under certain circumstances. (If you are not interested in the minu ae of Date calcula ons, stop reading
now and just use the calculator!).

AWKWARD CALENDARS
'Thirty days have September, April, June and November' . . . We are taught this rhyme when we are young, and
learn to cope with the diﬀerent number of days in each month over many years. However, innocent as it
sounds it provides many a stumbling block when working out the interval between two days. The numbers of
days between two dates is always unequivocal, but if we want to give this as 'x Years, y Months, z Days' we
come across problems of interpreta on. The following sec ons give examples of these problems and describe
how Chronolator deals with them. There is no single 'right method'; we hope that Chronolator's results match
most people's interpreta ons.

EASY CALCULATIONS
When the Day number of the later date is equal to or larger than that of the early date, things are quite
straigh orward:
Early Date

Late Date

Interval

23 January 2001

25 June 2002

1 year, 5 months, 2
days

01 December 2001

02 January 2002

0 years, 1 month, 1 day

SLIGHTLY HARDER CALCULATIONS
When the Day number of the later date is less than that of the early date, things can get a bit harder. However,
as long as the Day number of the early date is less than or equal to the number of days in the month before the
later date, there is not too much of a problem:

© 2021 Berrick Computing Ltd. All Rights Reserved.

Using Chronolator Documents

39

Early Date

Late Date

Interval

31 January 2001

01 June 2002

1 year, 4 months, 1 day

Most people would probably work this out as follows:
1. One year from 31 January 2001 = 31 January 2002
2. Adding 4 months takes us to 31 May 2002
3. Adding 1 ﬁnal day gets to our target, 01 June 2002
4. That is, 1 year, 4 months, 1 day in all
So far, so good!

DIFFICULT CALCULATIONS
Now look at what happens when the Day number of the early date is more than the number of days in the
month before the later date:
Early Date

Late Date

Interval

31 January 2001

01 May 2002

??

Comparing this to the previous example, 01 May 2002 is exactly one month earlier than 01 June 2002, so we
might expect the answer to be exactly one month less; that is, 1 year, 3 months, 1 day.
However, if we use the same method as above:
1. One year from 31 January 2001 = 31 January 2002
2. Adding 3 months takes us to 31 April 2002!
3. But April only has 30 days, so we must already have arrived at 01 May 2002
That being the case, our interval is 1 year, 3 months, 0 days in all - one day less than expected!

THE CHRONOLATOR SOLUTION
The Age and Interval Calculator works so that the above 'surprise' does not occur. From a date at the end of a
month to the ﬁrst of another month is always x Years, y months, and 1 day. For example:
Early Date

Late Date

Interval

31 January 2001

01 May 2002

1 year, 3 months, 1 day

30 April 2001

01 March 2004

2 years, 10 months, 1
day

31 May 2004

01 December 2005

1 year, 6 months, 1 day

This solu on looks very plausible, but it does give rise to an anomaly. For example, the interval from 30 January
to 01 May is the same as that from 31 January!
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Late Date

Interval

30 January 2001

01 May 2002

1 year, 3 months, 1 day

31 January 2001

01 May 2002

1 year, 3 months, 1 day
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On balance, we feel that this solu on most likely does accord with what most people want. However, if you
disagree, please let us know by making a sugges on at www.chronolator.com/suggest-form.htm.

9.2 WORKING WITH THE ABBREVIATIONS GLOSSARY
The Case Review Administrator can deﬁne entries in the Abbrevia ons Glossary of a new Internal
Chronology (see Se ng Up Chronolator Documents for details of how to do this). Those entries cannot
be changed or deleted by anyone else.
However, anyone can add and change their own entries. Chronolator keeps track of what abbrevia ons
have been deﬁned in which document.
Abbrevia ons can be up to 10 characters long, and their Deﬁni ons up to 30.
Processing the Abbrevia ons Glossary can be slow in a large ﬁle. Consider using the Chronolator
Browser Tools if this aﬀects you - they are much faster.

VIEWING AND PRINTING ABBREVIATIONS
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The Abbrevia ons Glossary form is displayed showing the abbrevia ons in
the document and their deﬁni ons:

The Deﬁned by / in column shows where an abbrevia on has been deﬁned.
In an Internal Chronology, it will state either Administrator or This Document.
In a Composite Chronology, it will include the Source Preﬁxes of any imported
documents, as shown above.
If you want to produce and print a list of the abbrevia ons, press the Save as
Document bu on.
When you have ﬁnished, close the form by pressing the Close bu on.

ADDING AN ABBREVIATION
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The Abbrevia ons Glossary form is displayed showing the abbrevia ons in
the document and their deﬁni ons:

Type the new Abbrevia on and
its Deﬁni on in the boxes, and
press Add:
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The new entry is added to the
list:

CHANGING AN ABBREVIATION
Since agencies can add their own entries to the Abbrevia ons Glossary, it is possible that two of them
might add similar entries (for example, AD/Alan Daniels and AD/Adam Donoghue). Chronolator always
keeps track of where an abbrevia on has been deﬁned, but if you want to use the Anonymisa on
feature all abbrevia ons and deﬁni ons must be unique.
You can use the Tools > Glossary > Edit tool to change a user-deﬁned Glossary entry. Chronolator
updates the glossary and makes any required changes in the document.
The following example uses the Abbrevia on GP1 and corresponding Deﬁni on Arthur Clements shown
in the example above. The document text contains this event (Arthur Clements is in column 4, and GP1
in column 5):
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Press Tools > Glossary > Edit:

The Abbrevia ons Glossary form is displayed.

Click GP1 Arthur Clements. and
press Change.

The current abbrevia on and
deﬁni on appear in the boxes
near the bo om of the form,
with a message invi ng you to
change them:
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Type in the new informa on
and press the Change bu on to
the right of it. In this example,
we change both the
Abbrevia on and the Deﬁni on
to GP99 and Xaviera Yarrup
respec vely, but you can
choose just to do either one.

The updated abbrevia on is
shown in the list.
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Use the scroll bar at the
The original entry is s ll there, so you can always ﬁnd it in the document in
bo om of the abbrevia ons list which it was ﬁrst deﬁned:
to scroll it to the right.

If you are using this feature to anonymise a document, remember not to
publish it without ﬁrst using the Publish > Exact Copy tool to produce a
copy without any Chronolator code, and hence without the ability to
reveal the abbrevia ons.
Press the Close bu on in the
bo om right hand corner of
the form.

Chronolator updates the document with the changed entry: GP1 and Arthur
Clements are changed to GP99 and Xaviera Yarrup respec vely:

BROWSING A DOCUMENT USING THE ABBREVIATIONS GLOSSARY
The Review bu on on the Abbrevia ons form lets you use a glossary entry to navigate through the
chronology. You can also produce extracts containing just the events pertaining to an entry.
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For example, suppose
you want to scroll
through a document
looking for events
involving, say, GP1.
Press Tools > Glossary
> Edit, select GP1, then
press Review.

For further details, see Reviewing and changing how entries in the Abbrevia ons Glossary appear in the
text (sec on 9.3). It describes the Review bu on on the Anonymisa on form, which lets you process
more than one glossary entry at a me - you can only process a single one with the Review bu on on
the Abbrevia ons Glossary form.

9.3 ANONYMISATION AND PERSONALISATION
Chronolator can anonymise a document according to the entries in the Abbrevia ons Glossary. It can be
hard for a reviewer to build up a mental picture of the people involved in a review when they are only
referred to by their ini als, so Chronolator lets you switch between anonymised and personalised views.
The Anonymisa on feature is found at Tools > Glossary > Anonymisa on and Review:

SWITCHING BETWEEN ANONYMISED AND PERSONALISED VIEWS
OF A DOCUMENT
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When you press Tools > Glossary >
Anonymisa on and Review, the Anonymisa on
form is displayed showing the abbrevia ons in
the document and their deﬁni ons.
Place a ck against the abbrevia ons you want to
process. The All, None, and Flip bu ons at the
top of the form can make this quicker.

A er you have selected one or more
abbrevia ons (in the example here, all have been
selected) the Anonymise and Personalise bu ons
work together with the Use forma ng checkbox.

If the Use forma ng checkbox is cked when a document is being Anonymised, the resul ng
abbrevia ons will be forma ed like this (i.e. Bold, Underlined and Italic). This has two advantages:
abbrevia ons stand out in the document
Chronolator can dis nguish between entries in the Glossary and any common words which are
spelt the same (for example, if there were an abbrevia on THE for Timothy Henry Edwards)
Such forma ng will be lost when some other
features are run, so it is recommended that you
do not use Anonymisa on un l you have ﬁnished
with those other features.
Chronolator warns you about this by displaying
Message 7010 the ﬁrst me you ck the Use
forma ng checkbox in a Word session.
See Message 7010 (sec on 12.8) for details
of which features might lose highligh ng.
Press OK to con nue.
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If the Use forma ng checkbox is cked when a document is being Personalised, only those
occurrences of an abbrevia on which are forma ed like this will be changed.

REVIEWING AND CHANGING HOW ENTRIES IN THE ABBREVIATIONS
GLOSSARY APPEAR IN THE TEXT
The Review bu on on the Anonymisa on form lets you use glossary entries to navigate through the
chronology.
During the review, you can change how individual entries appear in the text (as Abbrevia ons
with or without highligh ng, or as Deﬁni ons)
You can also produce extracts containing just the events pertaining to selected entries
Suppose we are interested in GP1/Arthur Clements and Midwife1/Paula Johnson.
Press Tools > Glossary > Anonymisa on and
Review to display the Anonymisa on form, ck
GP1 and Midwife 1, and then press the Review
bu on:

The Change Abbrevia ons form is displayed, and
occurrences of the entries are highlighted in the
document.
The ac ve occurrence is highlighted like this, and
the others like this.

Use the naviga on bu ons in the form to scroll
among the occurrences of GP1/Arthur Clements
and Midwife1/Paula Johnson:
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The radio bu ons let you change the text of the
ac ve occurrence to whatever you select:

When you have ﬁnished, press OK or Cancel,
depending on whether you want to save any
changes.

PRODUCING AN EXTRACT OF EVENTS CONTAINING SELECTED
GLOSSARY ENTRIES
You can produce a new document containing just the events pertaining to selected glossary entries.
Press Tools > Glossary > Anonymisa on and
Review to display the Anonymisa on form, ck
the desired entries, and then press the Review
bu on:

When the Change Abbrevia ons form is
displayed, press the Report bu on:
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A new document is created, containing only
those events which involve the glossary entries
you selected:
The counts at the top of the report pertain
to the abbrevia ons originally selected in
the Anonymisa on form, not those listed in
the report. Changes you make before
pressing Report will not be reﬂected in these
counts. Similarly, if some abbrevia ons are
forma ed, the report counts might not
match the highlights in the report.

9.4 WORKING WITH DUPLICATED ROWS
Use Tools > Duplicates to highlight or delete duplicated rows.

HOW DUPLICATED ROWS CAN OCCUR
Duplicated rows can occur for various reasons. For example:
you might have broken oﬀ comple ng an Internal Chronology for a while, and inadvertently
entered the same records twice
someone might send you a new version of an Internal Chronology containing a few extra events
when you have already merged the original into a Composite Chronology. Rather than having to
pick through it all and copy just the new events, you can import the new document in its en rety
and let Chronolator iden fy and delete events that were already there
Some mes however, duplicates - or near-duplicates - might occur for other reasons. It could be that two
diﬀerent agencies report the same event in exactly the same way. Although this might be unlikely,
Chronolator is designed to help you iden fy and analyse poten ally duplicated events however they
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occur.

HIGHLIGHT OR DELETE?
Chronolator can either highlight duplicated rows or delete them. You might want to highlight and review
them before dele ng them.
If you wish, Chronolator will save deleted duplicates in a separate document.

IGNORING THE SOURCE OF INFORMATION WHEN IDENTIFYING
DUPLICATES
You can instruct Chronolator to ignore the Source of Informa on column when looking for duplicates.
You might want to do this if you have inadvertently imported a Chronolator Document twice using two
diﬀerent Source Preﬁxes.

EXAMPLES
The various op ons are illustrated below using the following table. Although somewhat implausible, it
does provide a useful illustra on of the op ons.
All four rows are iden cal, except for the Source of Informa on entry in the second row, which says
Portmanor MC instead of Portmanor Medical Centre:
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HIGHLIGHTING DUPLICATES
When you press Tools >
Duplicates > Highlight,
the Highlight Duplicate Rows form
is displayed:

It contains a check box labelled
Ignore source column.

If you leave the check box blank
and press OK, only the last two
rows will be highlighted:

In contrast, if you ck the box
before pressing OK, the last three
rows will be highlighted:

The naviga on bu ons on the
Chronolator toolbar can be used
to go from one duplicate row to
the next in a long document.
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DELETING DUPLICATES
When you press Tools > Duplicates >
Delete, the Delete Duplicate Rows
form is displayed with an extra op on:

If you want to save any rows which are
deleted in a new document, ck the
Copy Deleted Rows check box.

A er you press OK, Chronolator tells
you it has deleted some duplicates (3
in this example).
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Press Go to list to switch to the new
document containing the deleted rows.
The descrip on of Message 3031
(sec on 12.4) has some
sugges ons about how you can
use the new document to recover
the deleted rows should you wish
to do so.

9.5 USING A SEQUENCE COLUMN
The ﬁrst column in a chronology table can be a Sequence column, which provides two main beneﬁts:
it can contain a reference number for each event
you can use it to specify the order of events on a par cular day when you do not know their mes

DEFINING A SEQUENCE COLUMN
The Case Review Administrator can deﬁne a Sequence column when se ng up the chronology
document.
End-users can deﬁne one using the Tools > Sequencing > Add column bu on. (This is the only change
Chronolator allows to Administrator-deﬁned column headings).
When adding a column this way, it is automa cally populated with sequence numbers.

CHANGING THE SEQUENCE COLUMN HEADING>
The default heading for a Sequence column is Seq, but you can change it a er it has been added (unless
it was deﬁned by the Case Review Administrator):
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Press Tools > Sequencing > Change Column
Heading

In the form which is displayed, type the new
heading - for example Reference - and press OK.

UPDATING EVENT REFERENCE NUMBERS
When adding a Sequence column, Chronolator automa cally adds a reference number to each event.
The numbers can be updated at any me – for example, if some events are added or removed.
Press Tools > Sequencing > Update – sequen al to give each
event a unique number:
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Press Tools > Sequencing > Update - group by day if you
want the numbering to start at 1 on each new day:

FORCING EVENTS INTO ORDER
Some mes you might not know at what me events happened on a par cular day, but you do know
their order. You can use the Sequence column to specify it.
In this example from a mul -agency chronology, the me
has only been given for one of the events of March 15, and
events are in the wrong order (in the ﬁrst one an infant has
collapsed, while in the second he seemed well):

We can put them in the right order by adding a Sequence
column (if there is not one already) and typing the correct
sequence numbers in it . . .
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. . . and then pressing Sort Tables > Ascending

You do not have to update sequence numbers in all the events, as the sort recognises decimal
numbers. For example, suppose that you now wanted to put event 4 before event 2 (this might not
make sense in terms of the story, but we will do it here just to illustrate the feature).
Replace the 4 in the event with a number between 1 and 2
- 1.5 say:

Press Sort Tables > Ascending to put the events into the
requested sequence:
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Press Tools > Sequencing > Update - group by day /
sequen al to replace any decimals with whole numbers:

If you force events into an incorrect date/ me sequence using a Sequence column, Chronolator will
detect the problem when it checks for errors.

SEQUENCE COLUMN CONFLICTS WHEN IMPORTING A
CHRONOLOGY
Because anybody can add a Sequence column it might happen that an Internal Chronology has one but
not a Composite Chronology - and vice versa.
When such conﬂicts occur, Chronolator lets you decide whether to keep or discard the column. See the
descrip ons of Messages 1030 and 1031 (sec on 12.2) for more details.

9.6 WORD TABLE TOOLS
Word's Table Autoﬁt Contents, Autoﬁt Window and Split at Current Row tools can be awkward to get to
in Word itself, so Chronolator adds them to the Tools menu.
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9.7 HIGHLIGHTING SOURCES OF INFORMATION
Chronolator can highlight events from diﬀerent agencies in a mul -agency chronology in several ways.
Agencies are dis nguished by the Source Preﬁx they are given when their chronologies are imported.
The highligh ng tool is found at Tools > Highlight Source > Deﬁne and Do:

WARNING
Highligh ng will be lost when some other
features are run, so it is recommended that
you do not do it un l you have ﬁnished with
those other features.
Chronolator warns you about this by displaying
Message 7010 the ﬁrst me you use the
highligh ng tool in a Word session.
Press OK to con nue.
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When you press Tools > Highlight Source >
Deﬁne and Do (and reply OK to Message 7010 if
it is issued), the Highlight Source op ons form is
displayed:

The main choices you make here use the bu ons in the Scope and the Colour Scheme boxes.

SCOPE
The Scope controls how much of the event is highlighted. The lowest scope highlights just the text of the
agency's Source Preﬁx, while the most extensive scope highlights the background of the en re row.
For example, here is how the agency Berrick Police would be highlighted using each Scope:

SCHEMES
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Chronolator's built-in Colour Schemes provide a quick way to set the highligh ng for all preﬁxes.
For example, this is the Mixed Colours scheme:

This is the Bright scheme:

The ﬁrst number in each coloured box is its Chronolator reference number, which can be used if you
want to override a scheme colour for a par cular agency.
The numbers in brackets give an idea of how legible the highlight might be when viewed on a computer
screen. They are calculated using the Web Content Accessibility Guidelines (Version 2.0) at
www.w3.org/TR/WCAG/. Higher values represent be er legibility. All the Chronolator Colour Scheme
highlights meet or exceed WCAG level AA.
A complete list of schemes can be created by pressing the Show Samples bu on.

CUSTOM SETTINGS
When there are only a few agencies in the chronology a default scheme should make it easy to
dis nguish each one. However, when there are lots of agencies you might get a be er dis nc on
between them by choosing highlights from diﬀerent schemes.
For example, in the Mixed Colours scheme it is quite easy to see the diﬀerences between the ﬁrst eight
highlights, but probably not so easy to dis nguish between highlights 004 and 014. In such a case, you
can override the scheme colour for one or more agencies by using the Custom Se ngs box on the
Highlight Source op ons form:
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Select the agency you want to modify, and then choose its colour by using the le /right arrows or typing
in its Reference Number. Note that you will not be able to type in a number that is already in use.
If you have set a custom colour for an agency, Chronolator will retain it when you choose a new
Colour Scheme unless Reset Custom Se ngs is cked.

PREVIEWING AND DOING
Highligh ng a large chronology can take a
few minutes. The Preview bu on quickly
produces a new document illustra ng how
each agency will appear.
When you are happy with your deﬁni ons,
press OK to highlight the chronology.

USING HIGHLIGHTS TO GET AN OVERALL PICTURE OF AN AGENCY'S
INVOLVEMENT
When reviewing a large chronology, you can get an overview of which agencies did what when by
highligh ng it and then using Word's Zoom feature to zoom out. For example, the following chronology
has been highlighted with Scope: Row and Colour Scheme: Bright, and zoomed to 10%:
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More sophis cated melines can be created using the Chronolator Reviewer's Tool at
tools.chronolator.com/review

9.8 PUBLISHING A CHRONOLOGY
When you have completed a chronology document you can publish it without the Chronolator program
code so that your recipients will not have to do anything about macros and licence terms whenever they
open it.
You can also:
publish the chronology in a variety of narra ve formats
create a document containing an analysis of the chronology
create a document that can be used by the Chronolator Browser Tools
Published chronologies are new documents: the original Chronolator document is not changed.

EXACT COPY
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Pressing Publish > Exact Copy
copies everything to a new
document, and then displays
Word's Save As dialog so you can
choose where to save it.

NARRATIVE FORMATS
Although tables are a good way to put a chronology together, they can be unwieldy to read, par cularly
when a single event has a lot of text in one column that spans several pages.
Chronolator can convert a chronology table to several narra ve formats, some of which include the
elapsed me since the start of the chronology.
Press Publish > Custom

The resul ng Published Document
Customisa on form lets you
customise the headings displayed
in the narra ve.

MAIN HEADING - SEQUENCE, DATE AND TIME
If the chronology contains a Sequence column, it will be the ﬁrst part of the main heading for each event
in the chronology.
The op ons in the Date / Time format box control how the rest of main heading is displayed:
As in document: date and me informa on will be copied exactly from the document
Elapsed: informa on about how long it has been since the start of the chronology is included. This
always includes the number of days. Two sub-op ons control how the me is treated:
Par al: the actual me of the event is used
Full: the elapsed me is used
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The dark grey box is updated as you change op ons to
illustrate their eﬀect:

OTHER HEADINGS
A er the main heading, the narra ve includes informa on from the non-blank entries for each event.
The Print column headings box controls whether their individual headings are included.

EXAMPLES
Take these events as an example:

This is how they will appear in the narra ve when various op on combina ons are used:
As in
Elapsed
document? Par al?

Elapsed
Full?

Print
column
headings?

Yes

No

Yes

No
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As in
Elapsed
document? Par al?

Elapsed
Full?

Print
column
headings?

Yes

No

No

No

Yes

No

Yes

No

Yes

Yes

No

No

No

Yes

No

No
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As in
Elapsed
document? Par al?

Elapsed
Full?

Print
column
headings?

No

Yes

No

No
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Result

ANALYSIS DOCUMENT
Pressing Publish > Analysis creates
a new document analysing event
reference numbers and counts
by Source of Informa on, and
then displays Word's Save As
dialog so you can choose where to
save it.
If you want to split the
chronology into separate me
periods for analysis, you can
do so by clicking in the table
where you want a split and
then using Tools > Table Tools
> Split at current row.
An analysis document contains four types of table:
Detailed Analysis by Source Preﬁx and Month
Summary Analysis by Source Preﬁx and Month
Totals by Source
Totals by Month
Here are some examples of each, taken from a chronology which has been split into me periods.
Individual agencies are highlighted as per any highligh ng applied with Tools > Highlight Source.
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DETAILED ANALYSIS BY SOURCE PREFIX AND MONTH

SUMMARY ANALYSIS BY SOURCE PREFIX AND MONTH
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TOTALS BY SOURCE

TOTALS BY MONTH
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JSON - CHRONOLATOR BROWSER TOOLS
Pressing Publish > JSON creates a
new document in the JSON
(JavaScript Object Nota on )
format that can be read by the
Chronolator Browser Tools.

The Chronolator Browser Tools at tools.chronolator.com use your web browser (e.g. Chrome) to process
chronologies.
It is important to note that only the so ware resides on the Web. Your Chronologies stay on your
computer, completely under your control. Their conﬁden ality is not compromised.
Web access is only required the ﬁrst me a tool is used, as the so ware is cached in the browser.
When this Help was published in early 2021, the available tools were:
Data Entry, which provides a means for people to enter events into a chronology. Events are
checked for errors as they are entered, meaning that the resul ng chronologies have fewer errors
than with Chronolator for Word, which relies on people using the Check Tables feature
Reviewer's Tool, which provides several features useful for reviewers, such as graphical melines
These tools are under con nual development, with new features being added much more o en than is
possible with Microso Word.
New tools will be also be added, such as an alterna ve to the Case Details Wizard in the Online
Workbench.
It is intended that the Browser Tools will eventually provide a complete alterna ve to Chronolator for
Word.

9.9 ADD-INS
If there is something extra you would like Chronolator to do, please contact us to discuss the possibility
of implemen ng it in an add-in.
Requests for new features have previously taken a long me to fulﬁl owing to the complexity of
incorpora ng them and then tes ng the whole product. Add-ins allow feature requests to be sa sﬁed
more quickly.
Chronolator Add-ins are Word templates (.dotm ﬁles). They should not be confused with the Addins tab on the Word Ribbon.
If a Chronolator Add-in is likely to be useful to a wide audience, it will be published on the Chronolator
web site. Links to available add-ins will be provided at www.chronolator.com/download.htm.
Add-ins include detailed instruc ons about how to use them. The rest of this sec on gives brief
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instruc ons about how to use a typical add-in, in this case called c8Addin40Age03.

LOADING AN ADD-IN
The ﬁrst step is to load the add-in into
Word. Press Tools > Add-ins > Load
add-in:

Word's Open dialog will appear.
Navigate to and open the add-in:

Add-ins are supplied with
instruc ons and a demonstra on
chronology. The add-in itself is the
.dotm ﬁle (usually the ﬁrst one in
the list).

Message 8000 conﬁrms the add-in has
loaded:
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Press OK to dismiss the message.

USING AN ADD-IN
A er an add-in has loaded, it updates
the Tools > Add-ins menu with its
func ons. In this case, the add-in has
provided op ons to add, delete, or
rename an Age column.
Add-ins are supplied with their
own detailed instruc ons.

9.10 DOCUMENT DETAILS AND SYSTEM INFORMATION REPORTS
The Document Details and System Informa on reports give informa on about the chronology document
and the Word and opera ng system environment in which it is running.

THE DOCUMENT DETAILS REPORT
The Document Details report contains informa on about the internal structure of the document (such as
what columns are included, whether they are mandatory and so on), and sta s cs about the tools used
while edi ng it.
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The Document Details report is displayed. Note the ver cal
scroll bar that allows you to page through it. A horizontal
scroll bar will also appear if necessary.

Press OK when you have ﬁnished looking at the report, or if you want to copy the informa on to a new
document, press Save As Document.
The various sec ons of the report are described below.

CASE REFERENCE

The Case Reference assigned by the Case Review Administrator.

COLUMN HEADINGS

A list of the headings for each column in the chronology table, iden fying any Special columns (sec on
7.2).

© 2021 Berrick Computing Ltd. All Rights Reserved.

Using Chronolator Documents

75

ABBREVIATIONS

The entries in the Abbrevia ons Glossary, showing where they were deﬁned and whether they are being
used during Chronolator error checking.

SOURCE PREFIXES

The Source Preﬁxes in a Composite Chronology, assigned when impor ng other chronology documents.

MISCELLANEOUS

The full name of the document, the order chosen when tables were last sorted, how many Chronolator
tables there are, and how many events are in the chronology.
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STATISTICS

Sta s cs about the tools used.
The Run column records how o en the tool has been used.
The remaining columns relate to the last me the tool was used, and are described below.
Tables

How many tables were in the document when the tool was started.

Rows

The number of events in the chronology tables (excludes the table headings).
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Field 1

Check Tables

The number of errors found.

Duplicates

The number of duplicates found.

Format Dates

Not used.

Add Sequence

Not used.
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Update Sequence Not used.
Clear Sequence

Not used.

Delete Sequence

Not used.

Change Seq Head Not used.
Merge

Not used.

Publish Custom

Not used.

Publish Analysis

Not used.

Normalise Src

The number of Source Preﬁxes.
Source preﬁxes are normalised if required before the Abbrevia ons
Review and Highligh ng processes. Normalisa on puts them into
the same format as deﬁned by the administrator who imported a
document. Normalisa on me is not included in the Elapsed me
for those processes, but is noted here.

Abbrev. Review

The number of glossary entries which were searched for.

Abbrev. Report

"

Anonymise

"

Personalise

"

Highlight Src

Scope (T= Text, CT=Cell Text, RT=Row Text, C=Cell, R=Row).
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Check Tables

Not used.

Duplicates

Not used.

Format Dates

Not used.

Add Sequence

Not used.

Update Sequence Not used.
Clear Sequence

Not used.

Delete Sequence

Not used.

Change Seq Head Not used.
Merge

Not used.

Publish Custom

Not used.

Publish Analysis

Not used.

Normalise Src

Not used.

Abbrev. Review

The number of glossary entries which were found. If preceded by an
asterisk, the Glossary column was included in the search.
cncl means the user cancelled the process.

Abbrev. Report

"

Anonymise

"

Personalise

"

Highlight Src

Colour Scheme (in full, except TxtWhi=Text on White,
C&G=ColoursAndGreys).

Elapsed Time taken.
MemPT Total physical memory on computer.
MemPF Free physical memory on computer.
MemVT Total virtual memory on computer.
MemVF Free virtual memory on computer.

SOFTWARE VERSIONS USED

The versions of Word and Windows used to produce the document. In a Composite Chronology, an

© 2021 Berrick Computing Ltd. All Rights Reserved.

78

Using Chronolator Documents

79

asterisk preceding the version informa on means that that version was used for one of the imported
chronologies.

SYSTEM PROCESSORS USED

The System Processors (CPUs) used to produce the document. The number in brackets at the start of each
line is the number of physical processors on the machine.

THE SYSTEM INFORMATION REPORT
The System Informa on report contains informa on about the Word and Windows versions on a
computer.
Press Help > About Chronolator

Press the System Informa on
bu on

© 2021 Berrick Computing Ltd. All Rights Reserved.

Using Chronolator Documents

80

The System Informa on report is
displayed. Note the ver cal scroll
bar that allows you to page though
it.

Press OK when you have ﬁnished looking at the report, or if you want to copy the informa on to a new
document, press Save As Document.
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WORKING WITH MICROSOFT WORD TABLES

This sec on provides some hints and ps about working with tables in Microso Word. Generally it gives
only one way of achieving a par cular end, but there are o en other ways. You can ﬁnd more
informa on in Word's Help, par cularly under 'Keyboard Shortcuts'.
It is always worth experimen ng and asking colleagues for ps. You might feel that you do not have
me to do so, but ten minutes spent once in a while to ﬁnd a new me-saver can save you much
more than that over the years.

10.1 TERMINOLOGY
Tables are composed of a number of Rows and Columns. Each individual 'box' where a row and column
meet is called a Cell.

10.2 USING A MOUSE
As you move the mouse over a table, the pointer changes. Some mes it points upwards from le to
right, some mes from right to le , some mes it is the inser on pointer, some mes a width adjuster,
and some mes a black arrow. What happens when you press the mouse depends on what the pointer
looks like.

Mouse pointer shapes

10.3 SELECTING ITEMS IN A TABLE
If you want to move or copy an item in a table, you must ﬁrst Select it. Word highlights whatever is
selected.
You can select items with the Mouse or with the Keyboard.

SELECTING ITEMS WITH THE MOUSE
The table below shows how to select table items with the mouse.
Be careful, because if you move the mouse while you are pressing it the eﬀect can some mes be
diﬀerent to what you want as the pointer changes.
Also, note that there is a diﬀerence between selec ng the text in a cell and selec ng the cell itself.
Item to be selected Mouse pointer Mouse ac on
Text in a cell

Press and hold at beginning of text, drag to desired end, let go.

Cell

Press le edge of cell.
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Row

Press to le of row.

Column

Press top edge of column.

Mul ple elements

Press as above and drag across the table as desired.

82

SELECTING ITEMS WITH THE KEYBOARD
The table below shows how to select table items with the keyboard.
Item to be selected

Key

Text in the cell to the right Tab
Text in the cell to the le

Shi +Tab

Mul ple elements

Shi + Arrow keys (experiment!)

10.4 ADDING ROWS TO A TABLE
To add a row to the end of a table, click the mouse anywhere in the bo om right hand cell and press the
Tab key.
To add a single row in the middle of the table, click in the row next to which you want it to go, right-click
the mouse, press Insert, and choose whether to insert Above or Below.
To add several rows to the middle of the table, select the desired number of rows next to which you
want the new rows to go, right-click the mouse, and press Insert (choose whether Above or Below). The
number of rows you selected will be added.

10.5 COPYING AND MOVING ITEMS IN A TABLE
When you have selected an item by one of the methods described above you can copy or move it to
another place with the Mouse or with the Keyboard.

COPYING AND MOVING ITEMS WITH THE MOUSE
Use Windows Drag and Drop. To Move an item, do the following;
Move the mouse over the selec on un l the pointer is an arrow poin ng upwards from right to
le like this
Press and hold the le mouse key
Move the mouse pointer where you want the item to go
Let go of the le mouse key
If you want to Copy instead of Move, hold the Ctrl key while you do the above.
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COPYING AND MOVING ITEMS WITH THE KEYBOARD
Use the Windows Clipboard shortcut keys to copy the selected item to the Clipboard:
Ctrl + C to copy and leave in place
Ctrl + X to cut from the current loca on
Move the Inser on Point to the desired loca on, and press Ctrl + V to paste the Clipboard into the new
loca on

UNDOING MISTAKES
Because of the many types of table elements you can select, it is easy to make a mistake. If you want to
undo a mistake, you can press the mouse on the Undo bu on on Word's Quick Access Toolbar, or press
Ctrl + Z on the keyboard.
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APPENDIX A – TROUBLESHOOTING

If your problem is not described here, please see the FAQ page on the Chronolator website
www.chronolator.co.uk/faq.htm, which contains informa on about problems encountered a er this
document was produced.
Many of the ac ons described below depend on what version of Word you are using. If you are unsure,
refer to How can I tell which version of Word I am using? (sec on 2.2)

11.1 THE CHRONOLATOR TOOLBAR DOES NOT APPEAR
The Chronolator toolbar should be added to any other custom toolbars on the Add-Ins tab on the
Ribbon.
Before Word adds it, it might require you to allow some ac ons. In par cular:
you might need to Enable Edi ng if the document opens in Protected View
you might need to Enable macros, depending on your macro security se ngs
You will also need to accept the terms of the Chronolator licence if you have not already done so since
you opened Word.
For details, please refer to the following:
Protected View (sec on 15.1.1)
Enabling macros (sec on 15.1.2)
Licensing (sec on 15.1.3)

11.2 THE CHRONOLATOR TOOLBAR HAS DISAPPEARED
If the Chronolator toolbar was there when you opened the document but is no longer visible, you might
have hidden the Ribbon by accident.
If so, click the Add-ins tab to show the Chronolator toolbar.

MAKING THE RIBBON PERMANENTLY VISIBLE
You can make the Ribbon stay visible if you want. Right-click between any of the tab labels (Home and
Insert for example) and un- ck Minimise the Ribbon or Collapse the Ribbon:
Word 2010
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Word 2013

Word 2016 and later

You can also toggle the Ribbon between visible and invisible states by pressing Ctrl + F1 .

11.3

THE CHRONOLATOR TOOLBAR DOESN'T HAVE ALL ITS
BUTTONS

Chronolator only puts bu ons on the toolbar if they can do something useful in the current document for example, since the only thing you can do with a fresh Composite Chronology is to import tables into
it, the only bu ons are Import Tables and Help.
Having said that, Word hides bu ons from the toolbar or ribbon if your window is too small. To get them
back, just widen or maximise the window.

11.4 THE CHRONOLATOR PROGRESS BAR DISAPPEARS
Chronolator informs you about the
progress of most tasks using the
Progress Bar. For example, while
you are checking tables it might look
something like this:

Some mes, if you are processing a very large ﬁle on an older computer with not much memory, or on a
slow network, the progress bar can disappear from me to me. If this happens, it is o en possible to
make it visible again by double-clicking on the document's icon in the Windows Task Bar.
Disappearance of the progress bar does not aﬀect the processing which is being done. When it has
ﬁnished, Chronolator will display a comple on message as usual.

11.5 RECOVERING CORRUPTED CHRONOLATOR DOCUMENTS
Like any Word document, a Chronolator document can become corrupted if problems occur on your
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computer or network while you are working on it. Symptoms can vary. For example:
Microso Visual Basic messages about a 'Run- me Error'
Badly forma ed or corrupted tables or text
Word crashes or stops working
The next few paragraphs describe what you can do to try to recover them.

RUN-TIME ERRORS
Chronolator uses macros and variables which are
hidden inside the document. If they become
corrupted, you might get a message similar to this:
The actual 'Run- me error' number and
descrip on can vary.

To recover from this, you will need a blank Chronolator Document. If you s ll have the original which
was sent to you, you should use that. If not, contact the person who sent it to you and ask for another
copy.

PROCEDURE
Step 1. Open the blank Chronolator Document
Step 2. Use Word's Insert File
tool
(press Insert > Object > Text
from ﬁle)
Step 3. Navigate to and select
the corrupted document and
press Insert

Step 4. Save, close and re-open the document.
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If the document is OK when you re-open it, you have successfully recovered your document and can
carry on with your work.
If not, or if the Insert fails:
1. follow the instruc ons in the next sec on Corrupted tables or text, or Word stops working in this
sec on
2. go back to Step 1 in this sec on above, and then in Step 3, insert the ﬁle you will have created in
the next sec on

CORRUPTED TABLES OR TEXT, OR WORD STOPS WORKING
If the tables or text in the document have become corrupted, or Word stops working, try using Word's
Open and Repair facility, which is available from Word's standard Open dialog.

REACHING THE OPEN DIALOG
You reach the Open dialog in diﬀerent ways depending on your version of Word:
In Word 2007, press

> Open.

In Word 2010 and later
versions, press the File tab.

What to do when you have opened the File tab also depends on your version of Word:
In Word 2010 and Word 2013,
press Open, then Computer, then
Browse
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In Word 2016 and later
versions, press Open, then Browse

USING OPEN AND REPAIR FROM THE OPEN DIALOG
Navigate to the corrupted
document, but do not le - or
double-click on it; if you do, it will
open without giving you the
opportunity to repair it.
1. right-click on it to select it
2. press the small arrow to the
right of the Open bu on
3. press Open and Repair

The op ons you see when
pressing on the small arrow
will vary depending on your
version of Word.
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Word will try to recover your ﬁle.
If it succeeds, it will display a list
of any problems it has corrected.

Press Close to close the list, and
then save the ﬁle.

11.6 SLOW PROCESSING
If you ﬁnd that Chronolator is running unusually slowly, it can some mes help to close Word and start
again - don't forget to save your work ﬁrst!
For example, on one occasion while Version 3 was being developed, it was found that upda ng
sequence numbers in a large ﬁle was taking almost four minutes. A er saving, closing, and re-opening
the document, the me went down to just over one minute.
It is also worth no ng that the Chronolator Browser Tools run many func ons signiﬁcantly faster
than Chronolator for Word. See Working with the Browser Tools (sec on 4).

11.7 CONFLICTS WITH WORD ADD-INS
Some mes Word add-ins conﬂict with Chronolator. When that happens, you can start Word without
loading add-ins and then open the Chronolator Document from Word's Open dialog.

STARTING WORD WITHOUT LOADING ANY ADD-INS
You can start Word without any add-ins by following the instruc ons below.
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Locate the Windows key. It is usually somewhere
between the Ctrl and Alt keys near the bo om le
of your keyboard.

Hold down the Windows key and press R to open
the Run dialog

Type winword /a in the Open box
Note: there is a space between winword and
/a

Press OK

For most installa ons of Oﬃce, Word should start
without any add-ins.
If so, you have completed this procedure and can
now open the Chronolator Document from
Word's Open dialog.

In some installa ons, Windows
will be unable to ﬁnd Word

If so, press OK then con nue as follows.
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Press the Browse … bu on

Word's Browse dialog will be
displayed
Find Winword.exe

The default loca ons are as follows:
Word
2016

C:\Program Files\Microso Oﬃce\Root\Oﬃce16 or
C:\Program Files (x86)\Microso
Oﬃce\Root\Oﬃce16

Word
2013

C:\Program Files\Microso Oﬃce\Oﬃce15 or
C:\Program Files (x86)\Microso Oﬃce \Oﬃce15

Word
2010

C:\Program Files\Microso Oﬃce\Oﬃce14 or
C:\Program Files (x86)\Microso Oﬃce \Oﬃce14

In the Browse dialog, click
WINWORD.EXE, and then press
Open

The Run dialog will be
redisplayed, with the path to
Winword.exe in the Open box,
surrounded by quote marks
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Click in the Open box, use the
right arrow bu on to reposi on
the inser on point to the right of
the closing quota on mark at the
end of the path statement, and
type a space followed by /a
Press OK to open Word

Word will start without any add-ins. You can now open the
Chronolator Document from Word's Open dialog.
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APPENDIX B - CHRONOLATOR MESSAGES

12.1 MESSAGE TYPES
Chronolator messages fall into two main types:
Messages conﬁrming the results of some processing or oﬀering the user a choice of ac ons. These
messages are displayed on the Chronolator Message Form and have unique reference numbers. They
are described in the next sec on.
Brief messages describing errors found when checking tables. These messages appear as Tool ps
when the mouse is hovered over a table error, and are also listed at the bo om of a Chronolator
Document a er Check Tables discovers errors. They are described in Check Table Error Codes (sec on
12.10).

THE MESSAGE FORM
The Chronolator Message Form has three main parts:

The upper part contains the main
message.
The middle part contains a more detailed
explana on of the message, and suggests
what ac ons might be appropriate.
The lower part displays a four-digit
Message Reference Number, which can be
used to locate the message in the
following sec ons.

All the messages are shown below, together with further informa on and suggested ac ons if appropriate.

12.2 MESSAGES 1000 - 1999
Messages in this range are issued when impor ng, merging and sor ng tables.
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Tables imported
All Chronolator tables have been imported. You can merge them into a single table
by using the 'Merge Tables' bu on on the Chronolator toolbar.

Further
Informa on

Chronolator has imported tables from one document into another. The imported
tables appear a er those which were originally in the target document.
You can con nue impor ng more tables, or merge the tables together.

1003

Invalid document
The ﬁle you chose is not a Chronolator document and cannot be imported into a
new Composite Chronology.
Please refer to the descrip on of this message in the documenta on for sugges ons
about what to next.

Further
Informa on

A new Composite Chronology has no informa on about the requirements for a
par cular review un l you import a Chronolator Document.
Once this informa on is in place, Chronolator will import matching tables from any
Word document; but the ﬁrst document you import into a blank Composite
Chronology MUST be a Chronolator Document.

1004

Invalid document
The ﬁle you chose is not a Chronolator document, or it has internal inconsistencies
which are described below. It cannot be converted.

Possible causes

You are trying to convert a document that does not contain the informa on
Chronolator needs, or in which that informa on has been corrupted.
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Case References are diﬀerent
Composite Chronology: CaseReference1
Imported Chronology: CaseReference2
Press OK to con nue with import, or Cancel

Further
Informa on

Every Chronolator Document is assigned a Case Reference by the Case Review
Administrator in order to warn against accidentally merging documents which relate
to diﬀerent cases. The Case Reference of each document is shown in the message.

Possible causes

You are trying to import tables from a non-Chronolator document, or from a
Chronolator document which has a diﬀerent Case Reference.

Possible ac ons Press OK if you want to con nue with the import, or Cancel if you do not.

1006

Cannot import document into itself
Chronolator cannot import a document into itself.
Please choose a diﬀerent document to import.

1010

'Must-ﬁll' columns are diﬀerent in source and target documents
Press OK to con nue with import, or Cancel

Further
Informa on

Although Chronolator has found tables which have the correct column headings, the
'Must-ﬁll' columns are diﬀerent.

Possible causes

You are trying to import tables from a non-Chronolator document, or from a
Chronolator document from a diﬀerent case which has diﬀerent 'Must Fill' columns.

Possible ac ons Press OK if you want to con nue with the import, or Cancel if you do not.
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No Data Tables found in document
There are no tables in the document which match the required column headings.

Further
Informa on

Issued when you process a document which has no tables with the required column
headings.

Possible causes

If you are checking, sor ng, or forma ng a document, the table headings might
have been accidentally changed.
If you are impor ng a document, the headings in the document you are trying to
import do not match those in the composite.

Possible ac ons Check what column headings Chronolator expects, and if appropriate change table
headings in the problem document to match the deﬁned headings.
You can ﬁnd the expected headings by using the Admin > Show Document Details
bu on.
Alterna vely, use the Admin > New Table bu on to add a table with the correct
column headings to the bo om of the document. A er you have done so, either
copy any data you have already entered into the new table, or copy the heading row
from the new table into that of the old one.

1016

No events found in document
There are no events in the document

Further
Informa on

Issued when the only Chronolator table in the document contains no events.

Possible causes

If there is a table that does contain events, its headings have been changed.

Possible ac ons See the sugges ons for Message 1015 in this sec on above
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Document level mismatch
The document you are trying to import cannot be imported into this document as it
was created with a higher level of Chronolator.
Create and use a new Composite Chronology using the higher level document for
this review. Refer to the manuals if you require step-by-step instruc ons.

Further
Informa on

Chronolator documents are generally backwards-compa ble; that is, newer version
documents can read older version ones. However, it is not possible to guarantee
forwards-compa bility.

1025

Conﬂic ng and Mul ple Deﬁni ons
The document you are trying to import includes some abbrevia ons and deﬁni ons
which could be confused with those in this one. Although Chronolator will keep
track of what was deﬁned where, reading the document might be confusing.
If you want to use the anonymisa on / personalisa on feature in the Composite
Chronology, you must ﬁrst resolve these conﬂicts by changing the abbrevia ons in
one of the documents.
Press Go To List to review the conﬂicts, OK to con nue with the import, or Cancel.

Further
Informa on

Chronolator will import a document with conﬂic ng and mul ple entries in the
Abbrevia ons Glossary, but if you want to anonymise or personalise the document
you must resolve these anomalies. You will be able to do this in the Composite
Chronology a er import, but it is recommended that you do it in the source
document before impor ng it.

1026

Conﬂic ng Deﬁni ons - Import Cancelled
You have chosen to save the conﬂic ng deﬁni ons in a new document. Chronolator
assumes this is because you want some me to review them, and will therefore
cancel the Import.

Further
Informa on

Issued if you press Go To List in response to Message 1025.
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User-deﬁned sequence column found
The document you are trying to import includes a user-deﬁned Sequence column. It
was probably added because the person comple ng the document wanted to be
exact about the order of certain events whose exact mes were unknown.
Chronolator can either add a Sequence column to the table(s) in this document, or
delete the one in the document being imported.
Press Add to add a Sequence column to the table(s) in this document, Delete to
delete the one in the document being imported, or Cancel.

Further
Informa on

Recommenda on: Press Add to add a Sequence column to the Composite
Chronology so that you can con nue to preserve the correct order of events. A er
you have done so, you can use the Tools > Sequencing menu to add numbers to the
remaining events.
If you choose Delete, the Sequence column remains in the document being
imported but is not carried across.

1031

Sequence column not found
The document you are trying to import does not include a Sequence column, but is
suitable for import in all other respects. Chronolator can either delete the Sequence
column from the table(s) in this document, or add one to the document being
imported.
Press Add to add a Sequence column to the table(s) in the document being
imported, Delete to delete the one in this document, or Cancel

Further
Informa on

Recommenda on: Assuming you have deliberately added a Sequence column to the
Composite Chronology, press Add to add one to the document being imported (the
document itself is unchanged, just the version of it in the Composite Chronology).
A er you have done so, you can use the Tools > Sequencing menu to add numbers
to the imported events.
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Unable to import
Chronolator cannot import anything into this document because of the following
internal inconsistencies in its structure:
<list of inconsistencies>

Further
Informa on

The document you are trying to import is a Chronolator Document, but it has some
internal inconsistencies. These are listed in the message.

Possible causes

The internal variables which Chronolator uses to describe the document structure
have been lost or corrupted. This can some mes happen when impor ng
documents across a slow network, or it might happen if Word failed while the
document was being edited some me in the past.

Possible ac ons

if the document is on a slow network, copy it to your desktop and try impor ng
the copy
try Repairing the document as described in Recovering corrupted Chronolator
Documents (sec on 11.5)

1050

Your entry <newPreﬁx> is similar to the exis ng preﬁx <oldPreﬁx>
Chronolator will not use exactly what you entered.
You can either import the document using the exis ng preﬁx, or you can choose a
completely diﬀerent one.
Press OK to use the exis ng preﬁx.
To choose a diﬀerent one, press Cancel and then Import Tables again.

Further
Informa on

Chronolator keeps the list of Source Preﬁxes dy.

Possible causes

Your Composite Chronology already contains informa on from agency <oldPreﬁx>,
and you are trying to import another document with a similar Source Preﬁx.
For example, If a Composite Chronology already has an agency Berrick New Town
Clinic, Chronolator will stop you impor ng another chronology with a similar preﬁx
such as Berrick Newtown Clinic.
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Tables merged
All Chronolator tables have been merged into a single table. You can sort the new
table into the correct sequence by using the 'Sort Tables' bu on on the Chronolator
toolbar.

Further
Informa on

Chronolator has merged all the tables in the document.

1110

Cannot merge tables

The next thing you might want to do is to sort the events into chronological order.

A non-Chronolator table has been found in between the Chronolator tables. The
oﬀending table is selected. Please move or delete it and try again.
Further
Informa on

The document contains more than one Chronolator table, and among them is a
non-Chronolator table.

Possible causes

An ordinary Word table has been inserted by accident.
A Chronolator table has had its headings changed.

Possible ac ons If the table contains no data for import, delete it or move it to the end of the
document.
If the table does contain data for import, correct its headings so that Chronolator
recognises it as a Chronolator table.

1120

Mul ple chronology tables found
This document contains more than one chronology table.
Press 'Merge' if you want Chronolator to merge the tables and sort them before
processing.
Press 'Don't Merge' to process each table individually.
Press 'Cancel' to return to the document without doing anything.

Further
Informa on

It is normal to have mul ple chronology tables when assembling a Composite
Chronology, but in other circumstances it might come about by accident.
Chronolator therefore checks how many tables are in a document before most
major processes, and if there are more than one it oﬀers to merge and sort them
before con nuing.
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Table sorted
Events should now be in Date and Time sequence.
Some date and me formats can prevent a successful Sort. If that happens, use the
Format Dates bu on to put dates in the all-digital format and then sort the table
again. You can put the dates back to your preferred format a erwards if you wish.
If you know the order of events on a day but not exactly when they occurred, you
can use a Sequence column to put them in order. You can make one using the Tools
> Sequencing > Add Column bu on.

Further
Informa on

Chronolator puts events with unspeciﬁed Times or End Dates before those speciﬁed
with greater detail if the sort is Ascending, or a er them if it is Descending.
See Using a Sequence column (sec on 9.5) for details about using a Sequence
column.
(If the document contains mul ple tables, the message heading will be Tables
merged and sorted or Tables sorted individually according to the response to
Message 1120).

1201

Table sorted
Events should now be in Date and Time sequence.
Some date and me formats can prevent a successful Sort. If that happens, use the
Format Dates bu on to put dates in the all-digital format and then sort the table
again. You can put the dates back to your preferred format a erwards if you wish.
If you know the order of events on a day but not exactly when they occurred, you
can use the ﬁrst column to put them in order.

Further
Informa on

Chronolator puts events with unspeciﬁed Times or End Dates before those speciﬁed
with greater detail if the sort is Ascending, or a er them if it is Descending.
See Using a Sequence column (sec on 9.5) for details about using a Sequence
column.
(If the document contains mul ple tables, the message heading will be Tables
merged and sorted or Tables sorted individually according to the response to
Message 1120).
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Dates forma ed
All dates have been forma ed to one of Chronolator's standard formats.
If you would like future releases of Chronolator to oﬀer alterna ve date formats
please use the sugges on form on our web site www.chronolator.com.

Further
Informa on

Chronolator uses two main formats for dates:
dd mmm yyyy (e.g. 01 Feb 2005). This format takes up a small amount of space
while being unambiguous about months and days (compared to, say 01.02.05 –
is that the ﬁrst of February or the second of January?)
yyyy-mm-dd (e.g. 2005-02-01). This is the ISO 8601 format. It takes even less
space than the previous format and has the advantage of being an Interna onal
Standard, but most people ﬁnd it harder to read
The day of the week can be added to both of these formats.
If you would like to be able to set other formats, please contact us via our web site.

12.3 MESSAGES 2000 - 2999
Messages in this range are issued by the Online Workbench.
2000

Cannot ﬁnd Conversion Tool
Find the ﬁle < chronolator-conversion-tool.docm > from your original Chronolator
installa on and copy it into folder <folderName>.

Further
Informa on

When you create a new Chronology Document, Chronolator looks for the ﬁle
chronolator-conversion-tool.docm. It issues this message if it cannot ﬁnd it.

Possible causes

You have opened the Online Workbench directly from the installa on zip ﬁle. You
need to Extract All Files from the installa on ﬁle and open the extracted Online
Workbench.
The Conversion Tool document has been moved or deleted.
The Online Workbench has been moved, but not the Conversion Tool.

Possible ac ons Extract All Files from the installa on zip ﬁle.
Find the ﬁle chronolator-conversion-tool.docm and copy or move it into the folder
shown in the message.
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Cannot copy Conversion Tool
The Conversion Tool (chronolator-conversion-tool.docm) is open and cannot be
copied. Please close it and try again.

Further
Informa on

When you create a new Internal or Composite chronology, Chronolator tries to open
chronolator-conversion-tool.docm. It issues this message if the ﬁle is already open.

Possible causes

You have opened chronolator-conversion-tool.docm.

Possible ac ons Close chronolator-conversion-tool.docm and try again.

2002

Conversion Tool is wrong version
The Conversion Tool Document (chronolator-conversion-tool.docm) is the wrong
version for this Online Workbench. Please copy the correct Conversion Tool into
folder folderName.

Further
Informa on

When you create a new Internal or Composite chronology, Chronolator opens
chronolator-conversion-tool.docm. It issues this message if the ﬁle is a diﬀerent
version from the Online Workbench.

Possible causes

You have upgraded the Online Workbench without also upgrading the Master
Chronology.

Possible ac ons Install the correct version of chronolator-conversion-tool.docm in the folder shown
in the message.

2003

Cannot ﬁnd Master Chronology Text
Find the ﬁle < ChronolatorMasterChronologyText.docx > from your original
Chronolator installa on and copy it into folder <folderName>.

Further
Informa on

When you create a new Internal chronology, Chronolator looks for the ﬁle
ChronolatorMasterChronologyText.docx. It issues this message if it cannot ﬁnd it.

Possible causes

You have opened the Online Workbench directly from the installa on zip ﬁle. You
need to Extract All Files from the installa on ﬁle and open the extracted Online
Workbench.
The Master Chronology Text document has been moved or deleted.
The Online Workbench has been moved, but not the Master Chronology Text

Possible ac ons Install ChronolatorMasterChronologyText.docx in the folder shown in the message.
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Invalid document
The ﬁle you chose is not a Chronolator document and cannot be used as a model.
Please choose another ﬁle, or use the Chronolator defaults.

Further
Informa on

You can only use a Chronolator document as a model for a new one.

Possible causes

You opened an ordinary Word document when choosing an exis ng ﬁle to use as a
Model in the Case Details Wizard.

Possible ac ons Use a Chronolator document as a model, or use the Chronolator defaults.

2011

Invalid password
The password you supplied is incorrect. Please try again, choose another ﬁle, or use
the Chronolator defaults.

Further
Informa on

You entered the wrong password for a protected ﬁle.

Possible ac ons When Chronolator redisplays the Open dialog: enter the correct password, choose
another ﬁle, or use the Chronolator defaults.

2015

Invalid document
The Chronolator document you chose has internal inconsistencies and cannot be
used as a model. Please choose another ﬁle, or use the Chronolator defaults.

Further
Informa on

Informa on about the structure of a Chronolator Document is stored in document
variables. The document you have chosen as a model has inconsistencies in this
informa on, and it is not possible to use it as a Model.

Possible causes

Word might have ended abnormally when it last processed the document, causing
internal inconsistencies.

Possible ac ons Use a diﬀerent Chronolator document as a model, or use the Chronolator defaults.
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Invalid document
The Chronolator document you chose is a blank Composite Chronology and cannot
be used as a model. Please choose another ﬁle, or use the Chronolator defaults.

Further
Informa on

Informa on about the structure of a Chronolator Document is stored in document
variables. A blank Composite Chronology does not contain these variables, and it is
not possible to use it as a Model.

Possible ac ons Use a diﬀerent Chronolator document as a model, or use the Chronolator defaults.

2020

Cannot write document details in preamble
The area in the Master Chronology preamble where Chronolator writes informa on
about the headings in this Chronolator document cannot be found.
This aﬀects only the document preamble: the table and all Chronolator features will
work correctly, and it is safe to distribute the document.

Further
Informa on

When ﬁrst installed, the Master Chronology Text document
ChronolatorMasterChronologyText.docx contains a bookmarked area in which
Chronolator writes informa on about the column headings in a new Internal
Chronology. That area cannot now be found.
Chronolator does not write informa on about the headings in the preamble, but
con nues to create the remainder of the Internal Chronology.

Possible causes

You have customised the Master Chronology and have deleted the area and its
associated bookmark.

Possible ac ons If you want Chronolator to include informa on about the column headings, revert
to the original Master Chronology and redo your changes, being careful not to
delete the relevant area and bookmark.

12.4 MESSAGES 3000 - 3999
Messages in this range are issued when Chronolator checks the tables in a Chronology.
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Errors found in document (n)
Rest the mouse over the box with a cross to see a brief descrip on of each error.
Use the bu ons on the Chronolator toolbar to go from one error to the next, or
press the Go To List bu on to view a complete list.
When you have corrected the errors, press the Check Tables bu on again to remove
the highligh ng.

Further
Informa on

You pressed the Check Tables bu on, and Chronolator has found n errors.
Errors are highlighted in Turquoise, Yellow, or Purple. You can scroll from one error
to the next using the naviga on bu ons towards the right of the Chronolator
toolbar, or see a complete list of them by pressing the bu on to the right of the
naviga on bu ons.
Chronolator does not check for errors as you type, so you must Check Tables a er
making any correc ons in order to remove the highligh ng.

Possible causes

Refer to Check Table Error Codes (sec on 12.10) for informa on about each error
detected by Chronolator.

Possible ac ons No immediate ac on is necessary, but you should ensure that all errors are
corrected before returning or publishing the document.

3001

Some rows had the wrong number of columns - ﬁx these ﬁrst
Chronolator has corrected the number of columns in at least one row. However, it
could not be sure which entry should go in which column. You should review these
rows now and make sure their entries are in the right places.
It is important to do this now, because now that they have the right number of
columns they will not be caught in future checks unless they have other errors.
For ease of iden ﬁca on, the corrected rows are displayed with white text on a
purple background.
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Document contains errors - do you want to close it?
Please ensure that all errors are corrected before returning or publishing this
document.
Press Cancel to resume edi ng the document and correct them now.
Press OK to close the document and correct them later.

Further
Informa on

Chronolator has checked the document as you closed it, and has found errors. The
errors are highlighted in Turquoise, Yellow, or Purple. You can scroll from one error
to the next using the naviga on bu ons towards the right of the Chronolator
toolbar, or see a complete list of them by pressing the bu on to the right of the
naviga on bu ons.

Possible causes

Refer to Check Table Error Codes (sec on 12.10) for informa on about each error
detected by Chronolator.

Possible ac ons No immediate ac on is necessary, but you should ensure that all errors are
corrected before returning or publishing the document. If you want to correct them
straight away, press Cancel. If you want to do it later, press OK.

3010

Checked - no errors found
Chronolator has checked all the tables in this document and found no errors.

Further
Informa on

You pressed the Check Tables bu on, and Chronolator has found no errors in this
document.
The bu ons on the Chronolator toolbar which can be used to scroll through errors
are disabled.
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No changes found since previously checked
No data table appears to have changed since Chronolator last checked this
document.
Press Cancel to resume edi ng.
Press Check to re-check the document.

Further
Informa on

To save me, Chronolator makes a quick check to see whether anything has
changed since the last run of Check Tables.
It is possible that this check does not detect a change. If you are sure you have
updated the table press Check to re-check the document.

3012

Document contains no events
None of the Chronolator tables in this document has any events.

Further
Informa on

Chronolator does not create a Custom or Analysis document if there are no events
in a chronology.

3013

Document contains text a er chronology tables
The area a er the chronology tables is reserved for Chronolator and will be
overwri en if you con nue.
Press Cancel to return to the document and review the text Chronolator found. If
you want to keep it, move it before the chronology tables before you check the
tables again.
Press OK to delete the text and con nue.

Further
Informa on

You pressed the Check Tables or Duplicates bu on. Chronolator will overwrite
whatever follows the chronology tables in the document if you press OK.
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Error checking cancelled
Please ensure that you check for errors before returning or publishing this
document.
Also please note that if you have corrected some previous errors they might s ll be
highlighted un l the next me you check the document completely

Possible causes

You pressed the Cancel bu on while Chronolator was checking for errors.

Possible ac ons No immediate ac on is necessary, but you should ensure that all errors are
corrected before returning or publishing the document.

3020

Processing cancelled
No changes have been made.

Possible causes

You pressed the Cancel bu on while Chronolator was processing. Any changes
made before you pressed Cancel have been backed out.

3025

n duplicates found
You can use the bu ons on the Chronolator toolbar to go from one duplicate to the
next.

Further
Informa on

Chronolator found n duplicated rows and highlighted them.

Possible ac ons You can scroll from one duplicate to the next using the naviga on bu ons towards
the right of the Chronolator toolbar.

3030

n duplicates deleted

Further
Informa on

Chronolator found n duplicated rows and deleted them. The rows cannot be
recovered.

Possible ac ons If you want to be able to recover deleted rows in future, ck the Copy Deleted Rows
op on when dele ng duplicates.
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n duplicates deleted
Chronolator has saved the deleted rows. Press the 'Go to List' bu on to view them.
Tip: to re-import them, save the list in a convenient loca on and use the
c8ImportSpecial_1 macro. Refer to this message in the manuals for more
informa on

Further
Informa on

Chronolator found n duplicated rows and deleted them. The rows can be recovered.

Possible ac ons Press Go to List to view the saved rows (if you have already moved on before
reading this, you will ﬁnd the document is open in the current Word session - look
for 'Documentn' where n is a number).
Column widths in the saved list might be diﬀerent from those in the Chronology
Document, which can present a problem when copying them back in. There are a
couple of ways to circumvent this:
if you want to recover every row and are working in a Composite Chronology:
save the list as a new document
press Advanced > c8ImportSpecial_1 to import the saved document without
se ng a Source Preﬁx
merge the tables
if you want to recover only selected rows or are working in an Internal
Chronology:
in the saved list, select and copy the row(s) you want to recover
go back to the Chronology Document
add the same number of rows to the bo om of the chronology table
press in the ﬁrst blank cell you added to the chronology table
paste the copied row(s)

3035

No duplicate rows
Chronolator has checked all the tables in this document and found no duplicated
rows.

Further
Informa on

Un l Chronolator Version 3, iden cal rows separated by other non-blank rows were
not iden ﬁed as duplicates. From Version 3 onwards, duplicate rows will be found
wherever they occur in a table.
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Chronolator table contains ver cally merged cells
A Chronolator table in this document contains some ver cally merged cells. The
table will be ignored.
Use the Check Tables bu on to ﬁnd the problem cells.

Further
Informa on

A Chronolator table in the current document contains a cell which spans more than
one row; this is called a 'ver cally merged cell'. Chronolator is unable to process
tables containing ver cally merged cells.
Any other Chronolator tables in the document will be processed as usual.

Possible ac ons Use the Check Tables bu on to ﬁnd ver cally merged cells.
Insert one or more rows. Copy and paste any required text into them, then delete
the rows containing ver cally merged cells.

3103

Chronolator table contains ver cally merged cells
<document name>cannot be imported because a table in it contains some ver cally
merged cells.
Open the document and use its Check Tables bu on to ﬁnd the problem cells.

Further
Informa on

This message can be issued when you try to import a document into a new
Composite Chronology.
A Chronolator table in the document being imported contains a cell which spans
more than one row; this is called a 'ver cally merged cell'. Chronolator is unable to
process tables containing ver cally merged cells.
Chronolator will not import a document containing any Chronolator tables with
ver cally merged cells into a new Composite Chronology.

Possible ac ons A er Import processing completes, open the problem document. Correct the
problem as described under the 'Possible Ac ons' for Message 3100. Retry the
Import.
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Chronolator table contains invalid rows
<document name> cannot be imported because a table in it contains some rows
with the wrong number of columns.
Open the document and use its Check Tables bu on to ﬁnd the problem rows.

Further
Informa on

<document name> is a valid Chronolator Document, but a table in it has at least one
row with the wrong number of columns.

Possible ac ons Open the problem document. Press its Check Tables bu on and then take the
ac ons suggested in Message 3001. Retry the Import.

3107

<process> processing cancelled - invalid table
Word failed to process a Chronolator table. No changes have been made to this
document.
Retrying the process might succeed. If not, use the Check Tables bu on to ﬁnd (and
possibly automa cally correct) the problem.

Further
Informa on

In normal running, this message indicates that a Chronolator table contains at least
one column with cells of varying widths. Chronolator is unable to run <process> on
such tables.
This message can also occur under a peculiar set of circumstances with versions of
Word prior to 2013. In that case, retrying <process> can some mes be successful.
The Chronolator document will be restored to the state it was in before <process>
processing began.

Possible ac ons Retry <process>.
If that does not work, use the Check Tables bu on, which as part of its processing
rebuilds the table, and then try <process>again.
If the problem persists, contact your administrator and ask them to request support.
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<process> processing cancelled - non-uniform table
At least one of the tables in this document has a row with the wrong number of
columns. Please correct this and try again.
Hint: Use Check Tables to ﬁnd the problem.

Further
Informa on

Chronolator has found a table which, although it has the correct headings, contains
at least one row with the wrong number of columns.

Possible causes

Cells have been merged.
A row has been added with the wrong number of columns.

Possible ac ons Open the oﬀending document and press Check Tables. Chronolator will correct any
rows with the wrong number of columns and highlight them. You should check that
Chronolator has put the relevant informa on in the right columns before saving the
corrected document.

3110

Chronolator table contains nested table
A Chronolator table in this document contains at least one nested table. The table
will be ignored.
Use the Check Tables bu on to ﬁnd the nested table(s).

Further
Informa on

A Chronolator table in the current document contains a cell which in turn contains a
nested table. Chronolator is unable to process such tables.
Any other Chronolator tables in the document will be processed as usual.

Possible ac ons Use the Check Tables bu on to ﬁnd nested tables. Having found one, select it and
convert it to text. Cut and paste informa on into the correct columns.
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Chronolator table contains nested table
<document name> cannot be imported because a table in it contains at least one
nested table.
Open the document and use its Check Tables bu on to ﬁnd the nested table(s).

Further
Informa on

A Chronolator table in <document name> table contains a cell which in turn
contains a nested table. Chronolator is unable to process such tables.
Nothing will be imported.

Possible ac ons Open <document name> and use its Check Tables bu on to ﬁnd nested tables.
Having found one, select it and convert it to text. Cut and paste informa on into the
correct columns. Retry the import.

3120

Chronolator table contains unexpected number of rows
Expected: m Found: n:
When Word prepared the table for processing, it did not ﬁnd the expected number
of rows.
No data will have been lost, but some might be misplaced (either on its own new
row, or appended to the previous row).

Further
Informa on

To make some of its processes faster, Chronolator gets Word to store tables in an
internal array.
This message is issued if the number of elements in the array does not match the
number of rows in the table.

Possible ac ons If you encounter this message a er pressing the Check Tables bu on, look for any
rows that are highlighted in purple, or check the error list for error code c8n100
(sec on 12.10).
If it occurs in other circumstances, pressing the Check Tables bu on might show
other errors resul ng from the poten ally misplaced data (for example, invalid
dates).
If Check Tables shows no errors, look through the document for misplaced data.
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Bulleted or Numbered list has been reforma ed
A Chronolator table in this document contained some bulleted or numbered lists.
These can cause problems when documents are merged. The bullets or numbers
have been removed.
Rather than using Word's list features, you could use 'o' characters or dashes for
bullets, or use ordinary numbers.

12.5 MESSAGES 4000 - 4999
Messages in this range are issued when Chronolator checks the status of your licence.
4000

Mul ple licences found
Chronolator found more than one licence ﬁle. Please delete old ones.
Look in the same folder as the Online Workbench for ﬁles whose names begin
'Chronolator40Licence'.

Further
Informa on

The Online Workbench found more than one licence ﬁle in its folder.

Possible causes

You have received a new licence and installed it in the correct folder without
dele ng the old licence.

Possible ac ons Delete the old licence(s), then close and reopen the Online Workbench.

4001

Mul ple licences found
Chronolator found more than one licence ﬁle. Please delete old ones.
Look in the same folder as the Conversion Tool for ﬁles whose names begin
'Chronolator40Licence'.

Further
Informa on

The Conversion Tool found more than one licence ﬁle in its folder.

Possible causes

You have received a new licence and installed it in the correct folder without
dele ng the old licence.

Possible ac ons Delete the old licence(s), then close and reopen the Conversion Tool.
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Invalid licence
Chronolator found a licence ﬁle, but it is not valid. Please re-install or delete it.
Look in the same folder as the Online Workbench for a ﬁle whose name begins
'Chronolator40Licence'. Replace that ﬁle with the licence supplied to you, or simply
delete it if you only want to evaluate Chronolator.

Possible causes

Licences are supplied as .txt ﬁles. The ﬁle might have accidentally been edited.

Possible ac ons Find your original licence and copy it into the same folder as
ChronolatorOnlineWorkbench.docm.

4006

Invalid licence
Chronolator found a licence ﬁle, but it is not valid. Please re-install or delete it.
Look in the same folder as the Conversion Tool for a ﬁle whose name begins
'Chronolator40Licence'. Replace that ﬁle with the licence supplied to you, or simply
delete it if you only want to evaluate Chronolator.

Possible causes

Licences are supplied as .txt ﬁles. The ﬁle might have accidentally been edited.

Possible ac ons Find your original licence and copy it into the same folder as chronolatorconversion-tool.docm.

4020

Licence Expired
Your licence has expired and this func on is not available.

Further
Informa on

Running Chronolator features requires a licence. Without a valid licence, only
standard Microso Word features are available.

Possible causes

Licence has expired.

Possible ac ons Depends on what document issued this message:
if issued by the Online Workbench, install a new licence ﬁle. then close and
reopen the Online Workbench. Details about how to get a licence can be found
on the Chronolator Web site at www.chronolator.com/licence.htm
if issued by an Internal or Composite Chronology, ask the Case Review
Administrator to send you a new licensed copy, and then copy the old document
into the new one
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Licence Expired
Your licence has expired. All standard Microso Word features remain available, but
Chronolator features are disabled.
Please visit www.chronolator.com for details of how to obtain a new licence.

Further
Informa on

Refer to Message 4020.

4040

Invalid Extension Password
The password you entered is not valid
Please contact your administrator.

Further
Informa on

When a Chronology Document licence expires, you can enter a password to extend
it.

Possible causes

The password you entered is invalid.

Possible ac ons Obtain a valid password from the person who sent you the document.

12.6 MESSAGES 5000 - 5999
Miscellaneous messages.

5100

Publish document?
Publishing a document makes a plain Word copy without any Chronolator code.
Readers of the copy will not have to agree to any licence terms. A er Chronolator
has created the copy, you will be prompted to save it.
Press OK to con nue, or Cancel.

Further
Informa on

If you circulate a Chronolator document, readers will have to think about macros
and accep ng licence terms when opening it. Use this bu on to produce a plain
Word document which contains no Chronolator code.

Possible ac ons Press OK to create a non-Chronolator copy, or Cancel.
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Cannot publish a document to the same name
Publishing the ﬁle using this name would make it lose all its Chronolator func ons.
Please try the save again using a diﬀerent name.

Further
Informa on

You have tried to publish a Chronolator Document using the same name as the
document. Overwri ng it in this way would stop its Chronolator func ons from
working.

Possible ac ons Choose a diﬀerent name for the published document.

5110

Could not copy styles
Chronolator encountered a Word error when trying to copy some of the styles used
in this document. Pagina on, text size and other forma ng a ributes might be
diﬀerent in the published version.
Try Publishing a second me when this a empt has completed: it will probably work
as expected.

Possible causes

Internal error in Word when Publishing a Chronolator Document

Suggested
ac ons

Retry Publishing.

5115

Publishing cancelled

If that fails, try Publishing to a diﬀerent loca on.

Report produc on was cancelled at your request.
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Publishing cancelled
At least one date/ me combina on in this document is not valid. Chronolator is
therefore unable to calculate elapsed mes.
Correct the date/ me combina on and try Publishing again.
(Sugges on: use the Check Tables bu on to ﬁnd any invalid date/ me
combina ons).

Further
Informa on

When you choose one of the Elapsed formats when Publishing a Custom
chronology, Chronolator needs to calculate the diﬀerence between when an event
started or ended and the start of the chronology. It can only do this if all non-blank
dates and mes are valid.

Possible ac ons Press the Check Tables bu on to ﬁnd any invalid date/ me combina ons, and
correct them.

5130

Show Chronolator error details in published document?
This document contains error highlights and / or a list of errors generated the last
me it was checked. Do you want to include them in the published version?
(If you do not, please note that page numbers might be diﬀerent in the published
version).

Further
Informa on

It is up to you whether to include details of errors in a published document.
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Cannot create Analysis Document
Sequence numbers are missing or invalid.
If the chronology document does not have a Sequence column, add one using
Tools > Sequencing > Add column.
If it does, update it using
Tools > Sequencing > Update – sequen al
A erwards, try Publish > Analysis again.

Further
Informa on
Possible causes

5141

An Analysis document requires valid sequence numbers in every event.
a table does not contain a Sequence column
non-numeric, blank, or duplicate entries in the Sequence column

Cannot create Analysis Document
Chronolator could not determine the date boundaries of table <tableNum>.

Further
Informa on

In order to analyse a table, Chronolator needs to determine the earliest and latest
events.

Possible causes

Either the earliest or latest date in the table, or both, cannot be determined.

Possible ac ons Use the Check Tables bu on to ensure all dates in the table are valid.

5143

Cannot create Analysis Document
Chronolator found an invalid date in the event with reference number <eventRef>.

Further
Informa on

In order to analyse a table, all dates must be valid.

Possible causes

The date of the event with reference number <eventRef> is invalid.

Possible ac ons Correct the date.
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Cannot create Analysis Document
Chronolator found an invalid source preﬁx in the event with reference number
<eventRef>

Further
Informa on

In order to analyse a table, all Source Preﬁxes must be valid.

Possible causes

The Source Preﬁx of the event with reference number <eventRef> is invalid.

Possible ac ons Correct the Source Preﬁx.

5200

Unsupported Word version
Chronolator requires Microso Word 2000 or later.
Press OK to con nue without Chronolator, or Cancel to exit Word.

Further
Informa on

Earlier versions of Word are not supported by Microso , so we would be unable to
oﬀer Chronolator support if the root cause of a problem was Word itself.

Possible ac ons Press OK to close the document.
Ask your IT department to upgrade Word. They might be persuaded to do so by
reading the informa on about Microso 's support lifecycle for Oﬃce programs at
h ps://support.microso .com/en-gb/lifecycle/search?alpha=oﬃce.

5210

Document type changed
Chronolator works by running macros, so documents must be saved as .doc or
.docm types. Chronolator will change the document to the correct type before
saving it.
If you want to save the document as another type, use the Chronolator Publish
bu on to make a plain Word copy and then save the Published copy in your desired
format.

Further
Informa on

Saving a document in a format which does not support macros would stop it being
able to use Chronolator.

Suggested
ac ons

Publish the document to make a plain Word copy which you can then save in any
other format.
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Performance recommenda on
Chronolator performs best when Word uses an op on that improves the
performance and reliability of any document stored on a network drive.
Press OK if you would like Word to use it.

Further
Informa on

Word XP introduced a performance improvement op on for documents stored on a
network. When the op on is set on, a network document is copied to a secure
loca on on your computer when you open it. You work on that copy. When you
save or close the document, Word moves it back to its network loca on. This can
lead to drama c improvements in performance, and also provides enhanced
protec on against network failure.
Unfortunately, when Microso introduced this op on they did not make it the Word
default. Chronolator can set it for you if it is not already on.
The op on applies to all documents, not just Chronolator ones.

Suggested
ac ons
Turning the
op on oﬀ

Press OK to allow Chronolator to set the op on
Close and re-open the document when prompted
If you decide later that you want to turn the op on oﬀ, you can do so as follows:
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On the main Word menu bar, press Tools > Op ons, then press the Save tab:

Un- ck Make local copy of ﬁles stored on network or removable drive.
Press OK.
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Word 2007 and later
Open the Op ons dialog (see Opening the Word Op ons Dialog (sec on 15.3) in The
Trust Center (sec on 15.3)).

Press Advanced and scroll down to Save.
Un- ck Copy remotely stored ﬁles onto your computer, and update the remote ﬁle
when saving.
Press OK.

5221

Performance recommenda on
Chronolator has set the op on. Please close and re-open this document to allow it
to take eﬀect.

Further
Informa on

See Message 5220.
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Change tracking alert!
<document name> is using Word's Track Changes feature. Tracking changes can
cause severe problems when processing tables.
Press OK to accept all tracked changes and turn change tracking oﬀ, or Cancel if you
want to review them.

Further
Informa on

Using Tracked Changes with tables can cause problems in any Word document, not
just a Chronolator one. Microso are aware of this, but at the me of wri ng there
is no ﬁx on the horizon.

5231

<process> cancelled - change tracking ac ve
<document name> is using Word's Track Changes feature.
The Tracked Changes feature can cause severe problems when processing tables.

Further
Informa on

The named <process> was cancelled because change tracking is ac ve in the
document <document name>.

Possible causes

You replied Cancel to Message 5230.
You replied OK to Message 5230, but Chronolator was unable to turn oﬀ tracked
changes.

Suggested
ac ons

Review the tracked changes if you wish, then retry the cancelled process and reply
OK to Message 5230.

5232

Unable to determine Tracked Changes status in <document name>
Chronolator could not determine whether Tracked Changes is on in the document
because it appears to be locked by another user.
To be on the safe side, Chronolator will assume that Tracked Changes is on.
The Tracked Changes feature can cause severe problems when processing tables.

Possible causes

Someone else is edi ng the document and Chronolator could not determine
whether Change Tracking is on.

Suggested
ac ons

Close the document and wait for the other person to close it as well. Reopen the
document.
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Unable to turn oﬀ Tracked Changes in <document name>
Chronolator could not turn oﬀ Tracked Changes.
This is probably because the document has been protected.
The Tracked Changes feature can cause severe problems when processing tables.

Possible causes

<document name> has been protected so that the Tracked Changes feature cannot
be turned oﬀ.

Suggested
ac ons

Turn oﬀ the protec on. You might need to supply a password.

5310

Web connec on error.

The relevant protec on feature can be found in various places:
Word 2013 and later- the Track Changes dropdown or the Restrict Edi ng
bu on on the Review tab of the Ribbon
Word 2010 - the Restrict Edi ng bu on on the Review tab of the Ribbon
Word 2007 - the Protect Document dropdown on the Review tab of the Ribbon

Word cannot open the Web site.
Please check your connec on is OK.
Further
Informa on

A Chronolator Web site cannot be found.

Possible causes

You do not have an open Internet connec on, or your organisa on might have
limited your access.

Possible ac ons Connect to the Internet or contact your IT department to grant you access to our
website as appropriate.
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Cannot save the document using the name you chose
A document with that name is already open in Word.
Please try the save again using a diﬀerent name.

Further
Informa on

Word does not allow you to save a document with the same name as one which is
already open.

Possible causes

You have tried to save a document using the same name as an open document.

Possible ac ons Retry the save using a diﬀerent name.

5321

Cannot overwrite Chronolator system ﬁle
Saving the ﬁle using this name might overwrite documents which Chronolator needs
to func on.
Please try the save again using a diﬀerent name.

Further
Informa on

Chronolator will not let you save a ﬁle using one of its own reserved ﬁle names
(chronolator-conversion-tool and ChronolatorOnlineWorkbench).

Possible ac ons Retry the save using a diﬀerent name.

5322

Permission Denied
You do not have Write access to the requested folder.
Please try to save the ﬁle in a diﬀerent folder.

Further
Informa on

You have tried to save the ﬁle in a folder to which you do not have Write access

Possible ac ons Save the ﬁle in a folder to which you do have Write access, such as My Documents.
If you think you should have Write access to the folder, contact your IT department.
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File might be temporary
This ﬁle looks like a temporary one, or is in a temporary folder. If you are unaware of
this you might not be able to ﬁnd it a er you close it.
A er you press OK, you will be asked to save the document using another name and
folder.
Please refer to the manuals if you frequently get this message.

Further
Informa on

You might have become a vic m of a bug in Word.

Possible ac ons Save the ﬁle in the right place with the right name.
If the message is issued o en, please ask your Administrator to contact Berrick
Compu ng, quo ng Message 5323.

5400

Internal inconsistencies in Chronolator document
Chronolator has found internal inconsistencies in this document, which are detailed
below.
These may stop Chronolator func ons working. Standard Word features are
unaﬀected.
<list of inconsistencies>

Further
Informa on

Informa on about the structure of a Chronolator Document is stored in document
variables. Inconsistencies in this informa on might stop some Chronolator func ons
working. However, standard Word func ons should not be aﬀected.

Possible causes

The document is stored on a slow network.
Word might have ended abnormally when it last processed the document, causing
internal inconsistencies.

Possible ac ons If the document is on a slow network, close it and try opening it again. If that does
not work, copy the document to your Desktop and work on that copy; remember to
move it back to the network when you have ﬁnished.
If the document is indeed corrupted, open a valid Chronolator Document with the
correct table headings (for example, the original document sent to you by an
Administrator), and copy the contents of the problem document into it. Save this
new document and use it from now on.
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Unable to create table
Chronolator cannot create a new table in this document because of following
internal inconsistencies in its structure:
<list of inconsistencies>

Further
Informa on

See Message 5400 for sugges ons about how to resolve these inconsistencies.

5403

Unable to set styles
Chronolator could not set some document styles because the ﬁle appears to be
locked by another user.
This will only aﬀect the fonts used to display any error messages at the end of the
document.

Further
Informa on

If there are any error messages at the end of the document, they might not be
displayed in the usual font.

Possible causes

Someone else is edi ng the document.

Suggested
ac ons

Close the document and wait for the other person to close it as well. Reopen the
document.

5500

Clipboard Unavailable
Chronolator could not access the clipboard. Another applica on is probably using it.
Press OK to try again, or Cancel.

12.7 MESSAGES 6000 - 6999
Chronolator issues these messages when an unexpected error occurs.
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Unexpected processing error
Please note the informa on below and report it to us using the form on our
website: www.chronolator.com/bug-form.htm.
<problem descrip on>

Further
Informa on

Chronolator has encountered an unexpected error. The problem descrip on
provided will help diagnose the error.

Possible ac ons Please note the problem descrip on and what you were doing at the me and send
the details to us using the form on the website. The more informa on you can
provide the be er. The Document Details and Word Environment reports will be
useful if you can produce them a er closing and reopening the document. See
Document Details and Word Environment Reports (sec on 9.10).

12.8 MESSAGES 7000 - 7999
Chronolator issues these messages when you use the Anonymisa on and Highligh ng features.

7000

Glossary contains similar entries
Anonymisa on and Personalisa on are not possible because the Abbrevia ons
Glossary contains abbrevia ons and / or deﬁni ons that are too similar to each
other..
You can update the glossary and related text using Tools > Glossary > Edit.
Press Review to see the relevant entries, or OK to dismiss this message.

Possible ac ons See Changing an abbrevia on (sec on 9.2).
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Warning!
Forma ng introduced while using the <feature> feature can be lost when Checking
or Merging Tables, processing Sequence numbers, and in some other circumstances
which are described in the 'Using Chronolator Documents' manual.
Press OK to con nue, or Cancel so that you can save your work and review the
manual before trying again.
This message will not be shown again during this session.
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The Bold, Italic, Underline forma ng which can be applied using the
Anonymisa on feature, and the colours applied by the Highlight Source feature can
some mes be lost.
This happens because Chronolator makes some compromises between convenience
and speed. When forma ng and colouring are lost it would be possible for
Chronolator to reapply it automa cally, but this could take me in a large ﬁle.
Instead of doing this, it warns you it might happen and directs you here for more
informa on.
The following bu ons and processes will ALWAYS destroy forma ng and colouring:
Check Tables
Tools > Duplicates > Highlight
Tools > Duplicates > Delete
Tools > Sequencing > Add
Tools > Sequencing > Update - sequen al
Tools > Sequencing > Update - group by day
The following bu ons and processes will SOMETIMES destroy forma ng and
colouring because they rely on the Source Preﬁxes in the Source of Informa on
column being in a uniform state (for example, having the right number of spaces
between words and being in the correct case). As long as the column is unchanged
from one run to the next, forma ng and colouring will be unaﬀected:
Tools > Glossary > Edit > Change
Tools > Glossary > Edit > Delete
Tools > Glossary > Edit > Review
Tools > Glossary > Anonymisa on and Review > Anonymise
Tools > Glossary > Anonymisa on and Review > Personalise
Tools > Glossary > Anonymisa on and Review > Review
Tools > Highlight Source > Deﬁne and Do > OK
The following bu ons and processes will SOMETIMES destroy forma ng and
colouring, either because the table has cells of diﬀerent widths or because a bug in
Microso Word erroneously thinks it has:
Tools > Sequencing > Delete
Tools > Sequencing > Clear
Import Tables (if the impor ng document has a Sequence column but the
imported one does not, or vice versa)
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Possible ac ons Do not use the Anonymisa on and Highlight Source features un l you have no
further need for the bu ons and processes known ALWAYS to destroy forma ng
and colouring before using.
Avoid changing the Source of Informa on column.

7030

Abbrevia on Not Used
The selected abbrevia on and deﬁni on are not used in the text.

7031

Abbrevia ons Not Used
The selected abbrevia ons and deﬁni ons are not used in the text.

7032

Nothing to anonymise
The selected abbrevia on is not used in the text.
OR
The selected abbrevia ons are not used in the text.

7033

Nothing to personalise
The selected abbrevia on is not used in the text.
OR
The selected abbrevia ons are not used in the text.

Further
Informa on

If the message includes the text 'with the speciﬁed forma ng', you have asked
Chronolator only to look for abbrevia ons which have Bold, Italic, Underline
forma ng by cking the box on the Anonymisa on form.
If the Use forma ng checkbox is cked when a document is being
Personalised, only those occurrences of an abbrevia on which are forma ed
like this will be changed.
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12.9 MESSAGES 8000 - 8999
Chronolator issues these messages when you use Chronolator Add-ins.

8000

Add-in loaded successfully
Please refer to the documenta on accompanying the add-in for details about what
it does and how to use it.

8010

Add-in failed to load
<document>
<error message>

Further
Informa on

Add-in <document> failed to load.
The reason is given in <error message>

Possible ac ons Ensure that <document> is a valid Chronolator Add-in for the version of Chronolator.
If you think it is, contact your Administrator and ask them to report the problem to
Berrick Compu ng. Give them as much detail as possible.

8020

Cannot open document - a Chronolator Add-in is loaded
Only one Chronolator document can be open while a Chronolator Add-in is loaded.

12.10 CHECK TABLE ERROR CODES
These messages appear as Tool ps when the mouse is hovered over a table error, and are also listed at
the bo om of a Chronolator Document a er Check Tables discovers errors.
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c8n100

This row contained the wrong number of columns. Chronolator has rec ﬁed this,
but you should check that the each entry is under the right heading

Further
Informa on

The number of columns in this row was diﬀerent from the number of column
headings. Chronolator has added or deleted columns to rec fy this. No data will
have been deleted, but it might not be in the correct column.

Possible ac ons Review where Chronolator has put the original data, and move it into another
column if necessary.

c8n120

This column is blank, but must always be completed. Add some text.

Further
Informa on

The Case Review Administrator has deemed it mandatory that this column should
always be completed.

Possible ac ons Add text to the column.

c8n125

'As Above', 'See Above', or di o marks are not allowed.

Further
Informa on

This can seem annoying when you are entering many similar events into an Internal
Chronology. However, remember that the Administrator will probably merge your
chronology with others. When merged chronologies are sorted, 'As Above' and
similar rows may well become separated from their previous predecessors.

Possible ac ons Copy and paste text from the previous row.

c8n130

Cell is ver cally merged. Copy any text to another row or rows and delete all rows
containing this cell.

Further
Informa on

The table cell in ques on spans more than one row; this is called a 'ver cally
merged cell'. Chronolator is unable to process tables containing ver cally merged
cells.

Possible ac ons Insert one or more rows. Copy and paste any required text, then delete all rows
containing the problem cell.
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c8n135

Cell contains a nested table. Convert the nested table to text.

Further
Informa on

The table cell in ques on contains a nested table. This can happen if you select the
relevant op on when pas ng from on table into another.

Possible ac ons Convert the nested table to text, and make sure the informa on it contains is under
the correct column headings.

c8n140

The '>' character is not allowed in this column.

Further
Informa on

Chronolator uses the '>' character to keep track of the Source of Informa on in a
Composite Chronology. It is, therefore, not allowed in the Source of Informa on
column in an Internal Chronology.

Possible ac ons Use a diﬀerent character.

c8n145

Invalid Source

Further
Informa on

The Source of Informa on column contains an invalid Source Preﬁx. Source Preﬁxes
are assigned when you import a chronology document and cannot be changed
a erwards.

Possible ac ons Press Admin > Show Document Details to see the list of preﬁxes which are valid in
this document.

c8n210

Invalid date, or invalid date format. Try another format (e.g. '01 feb 2006' or
'01.02.06').

Further
Informa on

Chronolator cannot interpret the date in this cell. It might be in a recognisable
format but be invalid (e.g. '32 May 2007'), or Chronolator might not recognise the
format.

Possible ac ons Enter a date in a recognisable format. Chronolator recognises most common date
formats.
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c8n220

Invalid me, or invalid me format. Try another format (e.g. '1.20 am', '0120', or
'01.20').

Further
Informa on

Chronolator cannot interpret the me in this cell. It might be in a recognisable
format but be invalid (e.g. '25:00'), or Chronolator might not recognise the format.

Possible ac ons Enter a me in a recognisable format. The message text indicates a number of
formats that Chronolator recognises.

c8n230

Event ends before it starts.

Further
Informa on

None.

Possible ac ons Change the start or end dates / mes of the event.

c8n240

Start of event is out of sequence.

Further
Informa on

None.

Possible ac ons Check the informa on about when the event started. If it is correct, you can use the
Sort Tables bu on to put the event in the proper place in the table.
Some mes you might get many of these errors. If so, go to the ﬁrst one and then
look at the event immediately before it; it is o en that one which is the root cause
of the problem.

c8n250

End of event is out of sequence.

Further
Informa on

None.

Possible ac ons Check the informa on about when the event ﬁnished. If it is correct, you can use
the Sort Tables bu on to put the event in the proper place in the table.

© 2021 Berrick Computing Ltd. All Rights Reserved.

Using Chronolator Documents

138

c8n300

At least one abbrevia on is not deﬁned. Change the abbrevia on, or use the Tools
> Glossary > Edit bu on to deﬁne a new one. Put mul ple abbrevia ons on
separate lines, or separate them with commas.

Further
Informa on

None.

Possible ac ons As suggested in the note.
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APPENDIX C - LICENSING

Chronolator is licensed so ware. You can evaluate its features without having a licence, but the
documents it creates include a watermark on every page. If you do not want these watermarks to
appear, Chronolator must be licensed.
When you open the ﬁrst Chronolator Document in a par cular Microso Word session, a form is
displayed where you can accept or decline the licence terms. The Licensee and Expiry Date are shown
on the form, and the full terms of the licence can be displayed by pressing the View Licence bu on. If
you do not accept them, the document will close.
Chronolator Documents and the Chronolator Online Workbench are licensed in diﬀerent ways.

ONLINE WORKBENCH LICENCE
When you buy a licence to use the Chronolator Online Workbench, you are given a small text ﬁle whose
name begins Chronolator40Licence.
The licence is speciﬁc to a par cular purchaser, and the licence ﬁle should not be distributed to anyone
else except as allowed in the licence terms.
Details about how to get a licence for the Online Workbench can be found on the Chronolator Web site
at www.chronolator.com/licence.htm.
To install the licence, copy it into the same folder as the Online Workbench. The Online Workbench
propagates the licence informa on into the Chronolator Documents it creates.

CHRONOLATOR DOCUMENT LICENCE
Chronolator Document licences are created by the Online Workbench and stored internally in the
Chronolator Document.

LICENCE PERIODS
A Chronolator licence is valid for a speciﬁed period.
For the Online Workbench, the period is contained in the licence ﬁle
Internal Chronologies are licensed for up to six calendar months from the day they are created,
subject to a maximum of one month a er the Online Workbench licence expires
Composite Chronologies created by the Online Workbench are licensed for the same period as
the Online Workbench
Composite Chronologies created by Local Administrators using the facili es included in an
Internal Chronology expire at the same me as that Internal Chronology
Internal Chronologies created by Berrick Compu ng Ltd under the terms of a Single Case licence are
licensed for the period agreed with the purchaser
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WHAT HAPPENS WHEN A LICENCE EXPIRES
When a licence expires, all the standard Microso Word features con nue to func on, but:
the Chronolator toolbar and bu ons do not appear
no Chronolator features are available
Chronolator Documents whose licence has expired can be imported into licensed Composite
Chronologies as if they were s ll licensed.

LICENCE EXTENSION
Unavailability of records and other factors can some mes delay the comple on of a Chronolator
Document beyond its expiry date. Chronolator Documents therefore provide a simple way to extend a
licence without having to contact Berrick Compu ng Ltd.
Star ng 30 days before a Chronolator Document expires, an Extend Licence bu on appears on the
Licence Acceptance form. Pressing it prompts the user to enter an Extension Password, which is
supplied along with the Online Workbench licence. Entering the correct password extends the licence
for up to three calendar months, subject to a maximum of one month a er the Online Workbench
licence expires.
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APPENDIX D - HOW CHRONOLATOR DEALS WITH EVENTS
WITH IMPRECISE DATES OR TIMES

In the real world, events begin and end on exact dates and at exact mes. In a chronology, not all this
informa on might be known for a par cular event. Indeed, in some chronologies, the administrator
might decide not to collect some of this informa on at all.
Chronolator always ensures that the Start Date of event is speciﬁed, but the Start Time, End Date and
End Time are o en missing. How does it deal with such events?

ASSUMPTIONS
INDIVIDUAL EVENTS
When informa on about the exact start or end of an event is missing, Chronolator makes the following
assump ons so that it can be processed.
if Start Time is missing, it is assumed to be midnight (00:00)
if End Date is missing, it is assumed to be the same as Start Date
if End Time is missing, it is assumed to be the same as Start Time

DURATIONS
Some mes the elapsed me between two instants needs to be calculated; for example, the interval
between two events, or between the start and end of a single event. Chronolator assumes that any
informa on missing in the later instant is the same as that of the earlier one.

ASSUMED INFORMATION IS NEVER DISPLAYED
Whatever assump ons Chronolator might make about missing informa on, it will never display those
assump ons explicitly. For example:
an event which Chronolator assumes to start at midnight, for example, will never include that me
in any display
a dura on based upon an assumed me will only include date-based informa on

OVERRIDING CHRONOLATOR'S ASSUMPTIONS
Some mes you might know the order in which events happen even though you do not know their dates
and me exactly. In these circumstances you can use a Sequence column to ensure that Chronolator
sorts events in the order you specify. The Check Tables bu on can s ll be used to check that such
'manually' sorted events are in a valid order. For more informa on about the Sequence column,
see Using a Sequence column (sec on 9.5).
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APPENDIX E - SUPPLEMENTARY INFORMATION

15.1 OPENING A CHRONOLATOR DOCUMENT
Word might require you to allow some ac ons before it ini alises Chronolator. In par cular:
you might need to Enable Edi ng if the document opens in Protected View
you might need to Enable macros, depending on your macro security se ngs
You will also need to accept the terms of the Chronolator licence if you have not already done so since
you opened Word.
For details, please refer to the following:
Protected View (sec on 15.1.1)
Enabling macros (sec on 15.1.2)
Licensing (sec on 15.1.3)

15.1.1 PROTECTED VIEW
Word some mes opens a document in Protected View, in which no edi ng is allowed. You must enable
edi ng if you want to make any changes to the document, let alone use its Chronolator facili es.
If you get a warning like one of
these, in which the Protected
View warning includes an Enable
Edi ng bu on, press it and then
see Enabling Macros (sec on
15.1.2).
If the Protected View warning
does not include an Enable
Edi ng bu on, click on the
warning to discover more
informa on, and con nue reading
here.
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The resul ng display tells you
more about why Word stopped
you edi ng the document and
oﬀers the opportunity to change
some se ngs.
In this example, you would press
File Block Se ngs . . .

. . . and then:
press the circle next to
Open selected ﬁle types in
Protected View and allow
edi ng
press OK a few mes un l
you return to the
Chronolator document
close and reopen the
document
press Enable Edi ng as
shown in the picture above
in this sec on

The File Block se ngs in the above example are just some of those which can make a document
open in Protected View. Other se ngs which ac vate Protected View can be found in the Trust
Center. See The Trust Center (sec on 15.3) to discover how to open it.
A er you have enabled edi ng in Protected View, you will probably need to Enable Macros.
See Enabling Macros (sec on 15.1.2) for details.

15.1.2 MICROSOFT WORD MACROS
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If, when you open a Chronolator Document, either the Licence (sec on 15.1.3) is displayed or the
Add-ins tab on the Ribbon has a Chronolator Toolbar (sec on 5), you do not need to read here any
further.
Word might – or might not – warn you that a document contains macros when you open it.
Before it does so, Word might open a document in Protected View. For more details, see Protected
View (sec on 15.1.1).
Chronolator works by using Word macros. Because they are computer programs, macros can be used to
propagate and run computer viruses. Word therefore allows you to prevent them running, since for
most documents they are unnecessary. However, for Chronolator they are essen al.
The following pages show you how to allow Chronolator macros to run without compromising your
computer.

DIGITALLY SIGNED MACROS
Chronolator Version 4.0 macros are 'digitally signed' by Berrick Compu ng Ltd, which means that Word
checks they have not been tampered with since they were published. If they have been, Word will not
allow them to run.
You can choose to trust all documents signed by Berrick Compu ng Ltd, in which case Chronolator
Documents will always run macros when you open them. This document shows you how.
Some mes your IT department might prevent you from making the changes described below. If so,
you might like to ask them to read Group Policy se ngs for Chronolator Macros.

ENABLING MACROS
Word usually informs you it has disabled macros by displaying a message under the Ribbon, with an
Enable Content bu on.
If you want to enable macros
just this once, press Enable
Content, and con nue reading at
Licensing (sec on 15.1.3)
If you want always to let
macros run in this document,
press Macros have been
disabled, and con nue reading at
Se ng a level of Trust in this
sec on.
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If Word does not inform you it
has disabled macros, press
File, and con nue reading at
Se ng a level of Trust in this
sec on.

SETTING A LEVEL OF TRUST
You can choose to enable macros each me you open a Chronolator Document. If you ﬁnd that
inconvenient, you can specify a level of trust in them:
To enable macros every me you open a par cular Chronolator Document, make it a Trusted
Document
To enable macros every me you open any Chronolator Document, you can make Berrick
Compu ng Ltd a Trusted Publisher
You set a level of Trust on the Info
tab in Word's Backstage View.
You can get to Backstage View by
pressing the File tab on the
Ribbon, or by pressing Macros
have been disabled if Word
displayed a security warning
when you opened a document.

Making a Trusted Document
If you make the document a Trusted Document, Word will automa cally enable macros in it whenever
you open it.
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In Backstage View:

Press Enable Content to see more
op ons.
Press Enable All Content.

If the document is on a network
loca on, Word might warn you
about it.
Press Yes.

Making Berrick Compu ng Ltd a Trusted Publisher
If you make Berrick Compu ng Ltd a Trusted Publisher, Word will automa cally enable macros in this
document and any other Chronolator Documents you receive in future.
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In Backstage View:

Press Enable Content to see more
op ons.

Press Advanced Op ons.

In the resul ng Microso Oﬃce
Security Op ons display:

Press Trust all documents from
this publisher.
Press OK.

WHAT IF I CANNOT ENABLE MACROS?
If for some reason you cannot enable macros, you can s ll update the document but you will not be able
to use basic Word Save (you will get a message about macros being disabled). In that case, you should
save your changes either:
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by using Save As, or
by closing the document and making the relevant reply when Word asks you if you want to save
changes

15.1.3 ACCEPTING THE LICENCE
Chronolator is licensed so ware. If
macros have been properly
enabled, a Licence screen is
displayed when you open the
Online Workbench or a
Chronolator Document.
Press OK to con nue using
Chronolator.
Press Cancel if you do not agree to
the licence terms. The document
will close.
Press View Licence if you want to
read the licence terms.
You are only asked to accept a licence once in a par cular Microso Word session.
Further details about licensing can be found in Appendix C (sec on 13).

15.2 PROTECTING A DOCUMENT WITH A PASSWORD
Word can protect your document with a password. Consult Word Help for full details, but here are two
methods.

USING THE FILE TAB
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and then press Info > Protect
Document > Encrypt with
Password and follow the ensuing
instruc ons.

USING SAVE AS
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You can also password-protect a
document by clicking on the Tools
> General Op ons dropdown on
the Save As dialog.

15.3 THE TRUST CENTER
The Trust Center is where you set security op ons for Microso Word. It is found in the Word Op ons
dialog.

OPENING THE WORD OPTIONS DIALOG
Press the File tab
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The Word Op ons
dialog is displayed

THE TRUST CENTER
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In the Word
Op ons dialog,
press Trust Center,
then press Trust
Center Se ngs.

The Macro
Se ngs bu on
controls whether
macros can run.
When set as
shown here, it
works in
conjunc on with
the Message Bar
se ngs
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The Trusted
Publishers,
Trusted Loca ons,
Trusted
Documents, and
Protected View
bu ons work
together to
inﬂuence when a
document opens
in Protected View.

To ﬁnd out more
informa on about
the se ngs you
can make a er
pressing one of
these bu ons,
click on it and
press ? at the top
right hand corner
of the display to
open Word Help
for the relevant
topic.
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15.4 ADVANCED MACROS
You should usually only run these macros if asked to do so by Chronolator support staﬀ.
The Advanced menu contains the following tools:
c8ImportSpecial_1
c8EnvironmentCleanup
c8CleanupAddins
c8NormaliseSourceOfInforma on
c8SetJSONParser
Some of these tools are also available using Word's Run Macro facility in case of problems with the
standard Chronolator toolbar.
You run a macro by pressing
Macros on the Developer tab of
the Ribbon:

You will be asked which macro you
want to run as shown here.
Select it and press Run.
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The Developer tab is only
shown on the Ribbon if the
Word Op on
Customise Ribbon > Developer
is cked:

15.4.1

IMPORTING A DOCUMENT WITHOUT ADDING A SOURCE
PREFIX

Macro c8ImportSpecial_1 imports a document as-is without adding a preﬁx to its Source of Informa on
column.

15.4.2 CLEANING UP THE CHRONOLATOR ENVIRONMENT
Chronolator stores some se ngs in the user area of the Windows Registry, and some mes saves your
work in hidden Word documents. It removes these things when the last Chronolator document in a
Word session is closed. If this removal were to fail (if Word crashes for example) it might aﬀect opening
the next Chronolator Document.
Macro c8EnvironmentCleanup performs the same clean-up that Chronolator does when it closes
normally.

15.4.3 UNLOADING CHRONOLATOR ADD-INS
The last Chronolator Document to be closed in a Word session should unload any Chronolator Add-ins. If
it fails to do so, you can run macro c8CleanupAddins, which will unload Chronolator Add-ins but leave
any others you might use in place.

15.4.4 NORMALISING THE SOURCE OF INFORMATION COLUMN
When processing abbrevia ons and highligh ng documents by agency, Chronolator relies on the Source
Preﬁxes in the Source of Informa on column being in a uniform state (for example, having the right
number of spaces between words and being in the correct case). Chronolator does this automa cally
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when needed, but the algorithm it uses to check whether it is necessary does not check every event in a
large ﬁle - to do so might take too long. There is, therefore, the possibility that abbrevia ons might not
properly be found and that highligh ng might not properly be applied.
Macro c8NormaliseSourceOfInforma on can be used to put the Source Preﬁxes in a uniform state if
required.
Note that any Bold, Italic, Underline forma ng applied using the Anonymisa on feature will be lost
and will need to be redone. If that is the case, Personalise the document without using forma ng, and
then Anonymise it using forma ng. See Anonymisa on and Personalisa on (sec on 9.3) for more
details.
Similarly, any colours applied by the Highlight Source feature will be lost and need to be redone.
Chronolator remembers the highligh ng which was last applied, so you just need to press Tools >
Highlight Source > Deﬁne and Do and then press the OK bu on on the Highlight Source op ons
selector.

15.4.5 SETTING THE JSON PARSER
Chronolator uses a JSON parser when conver ng a JSON ﬁle (as used by the Chronolator Browser Tools)
to Word. You can set which of the two installed parsers to use by pressing Advanced > c8SetJSONParser
and choosing op on 1 or 2.
If you need to use Word's Run Macro facility to set the parser, run c8SetJSONParser_1 or
c8SetJSONParser_2.
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GLOSSARY

A
Abbrevia ons Glossary
The Glossary contains Abbrevia ons and their Deﬁni ons that can be used to anonymise,
personalise, search and navigate the chronology.
Add-in
A stand-alone Word document that can be used to add func ons to a Chronolator
Document.
Add-ins
A Chronolator Add-in is a stand-alone Word document that can be used to add func ons to
a Chronolator Document.

C
Case Details Wizard
The tool in the Online Workbench that is used to deﬁne a new Chronology Document
Case Review Administrator
Someone who sets up a Chronology Document using the Online Workbench
Chronolator Browser Tools
Some tools that use your web browser (e.g. Chrome) to process chronologies.
It is important to note that only the so ware resides on the Web. Your chronologies stay on
your computer, completely under your control. Their conﬁden ality is not compromised.
See tools.chronolator.com.
Chronolator Document
A document containing one or more tables created by Chronolator
Chronolator Documents
Documents containing one or more tables created by Chronolator
Chronolator Online Workbench
The Word document (ChronolatorOnlineWorkbench.docm) used by a Case Review
Administrator to create Chronolator chronology documents
Chronology Document
A document containing one or more tables created by Chronolator
Composite Chronology
A Chronolator Document containing informa on from two or more organisa ons or
departments. O en referred to as a 'Mul -Agency Chronology'

I
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Internal Chronology
A Chronolator Document speciﬁc to a par cular organisa on or department
ISO 8601
ISO 8601 is an interna onal standard covering the exchange of date- and me-related data.
It was issued by the Interna onal Organiza on for Standardiza on (ISO) and was ﬁrst
published in 1988.

J
JSON
JavaScript Object Nota on. A text-based format for storing and exchanging data. Can be
read by any text editor, such as Notepad.
JSON parser
So ware that translates JSON into items that a computer can process.

L
Local Administrator
Someone who distributes an Internal Chronology for others to complete and then merges
the results into a Composite Chronology
London Child Protec on Procedures
London Child Protec on Procedures, Edi on 4, p510 (London Safeguarding Children Board,
2010 (www.londonscb.gov.uk))

M
macros
Macros are a standard feature of all Microso Oﬃce programs. They automate repe
tasks and commands by using Visual Basic for Applica ons programs.

ve

O
Online Workbench
The Word document (ChronolatorOnlineWorkbench.docm) used by a Case Review
Administrator to create Chronolator chronology documents

P
Preamble
The ﬁrst couple of pages in a new Internal Chronology. You can update it in any way you
like: Chronolator does not check it.
Protected View
A standard Word feature that protects your computer from viruses, worms, or other kinds
of malware that can harm your computer.
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Because Chronolator Documents contain macros, and macros can be used to create viruses,
Word some mes ﬂags them as poten ally harmful and opens them in Protected View.

R
Ribbon
The area at the top of the Word display

S
Source Preﬁx
Speciﬁes the agency or organisa on that provided the informa on about an event. You are
prompted to enter it when you import a chronology into a Composite Chronology, and
Chronolator adds it to the beginning of whatever is already in the Source of Informa on
column.

T
Trust Center
The area in the Word Op ons dialog that lets you set security op ons.
txt
A text ﬁle produced by one of the Chronolator Browser Tools. Although simple text, only the
Tools can make sense of it.

W
Windows Task Bar
The area along the bo om of the screen.
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Accep ng the Licence, 148
Administrators, 29
Advanced Macros, 153-155
Anonymisa on and Personalisa on, 47-51
Appendix A – Troubleshoo ng, 84
Appendix C - Licensing, 139-140
Appendix D - How Chronolator deals with events with imprecise dates or mes, 141
Checking for errors, 20-22
Cleaning up the Chronolator environment, 155
Composite chronology
Overview, 29
Step by Step Guide, 29-36
Conﬂicts with Word add-ins, 89-92
Correc ng errors, 22-26
Crea ng A Composite Chronology Document, 29
Documenta on, 4
Entering and checking events, 16
Entering data in the Chronology Table, 17
Glossary, 157-159
Help, 9-10
Highligh ng Sources of Informa on, 59-64
Licensing
Accep ng the terms, 148
Expired licences, 139-140
Licence types, 139-140
Macros
Advanced, 153-155
Conﬂicts with other programs, 89-92
Enabling, 143-148
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Security, 143-148
Microso Word Macros, 143-148
Opening a Chronolator Document, 142
Overview, 29
Prac se Using Chronolator, 9
Problem repor ng, 9-10
Process
diagrams, 5-8
overview, 5-8
Producing Composite Chronologies, 16
Produc vity Tools, 37
Produc vity Tools and Advanced Features, 16
Progress Bar
Disappears, 85
Protected View, 142-143
Publish
Analysis document, 64-71
Exact Copy, 64-71
Narra ve, 64-71
Publishing a chronology, 64-71
Recovering corrupted Chronolator Documents, 85-89
Se ng the JSON parser, 156
Slow processing, 89
Special Columns, 17-20
Step by Step Guide, 29-36
System requirements
general, 10
Microso Word, 8-9
The Age and Interval Calculator, 37-40
The Chronolator progress bar disappears, 85
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The Chronolator toolbar does not appear, 84
The Chronolator toolbar doesn't have all its bu ons, 85
The Chronolator toolbar has disappeared, 84-85
The Sort Tables bu on, 26-28
The Trust Center, 150-153
Toolbars
Composite chronologies , 14-15
Disappeared, 84-85
Do not appear, 84
Internal chronology , 14-15
Unloading Chronolator Add-ins, 155
Using a Sequence column, 55-59
Videos, 9-10
What is in a Chronolator Document?, 17
Word
Op ons dialog, 150-153
Trust Center, 150-153
Versions, 8-9
Word Table Tools, 59
Working with Chronolator Documents, 11
Working with Duplicated Rows, 51-55
Working with the Abbrevia ons Glossary, 40-47
Working with the Browser Tools, 12-13
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